Download

Build never ending...

Hey all,

Up front- I’m a huge noob so give me a break.

I’m trying to build and share an Unreal Tournament level, but my output log just stops at a certain point. It hasn’t failed or anything, it just doesn’t progress any further. I’ve built and shared this level in the past, the only difference is I’ve now imported an asset package and started texturing, meshing, and lighting it.

These are the last few lines of the output log:


LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-10.13.22:321]  0]LogSavePackage:Display: Finished SavePackage D:/UnrealTournament/UnrealTournamentEditor/UnrealTournament/Saved/Cooked/CTF-101v0011/WindowsNoEditor/UnrealTournament/Content/ParrySM/room_02_upper2_StaticMesh.uasset
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-10.13.22:322]  0]LogCook:Display: Cooking /Game/ParrySM/room_02_upper_StaticMesh -> D:/UnrealTournament/UnrealTournamentEditor/UnrealTournament/Saved/Cooked/CTF-101v0011/WindowsNoEditor/UnrealTournament/Content/ParrySM/room_02_upper_StaticMesh.uasset
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-10.13.22:326]  0]LogSavePackage:Display: Finished SavePackage D:/UnrealTournament/UnrealTournamentEditor/UnrealTournament/Saved/Cooked/CTF-101v0011/WindowsNoEditor/UnrealTournament/Content/ParrySM/room_02_upper_StaticMesh.uasset
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-10.13.22:327]  0]LogCook:Display: Cooking /Game/RestrictedAssets/Tutorials/tut_frameicon -> D:/UnrealTournament/UnrealTournamentEditor/UnrealTournament/Saved/Cooked/CTF-101v0011/WindowsNoEditor/UnrealTournament/Content/RestrictedAssets/Tutorials/tut_frameicon.uasset
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-10.13.22:329]  0]LogSavePackage:Display: No exports found (or all exports are editor-only) for tut_frameicon. Package will not be saved.
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-10.13.22:330]  0]LogCook:Display: Cooking /Game/RestrictedAssets/Audio/Movers/Attenuation_Lifts -> D:/UnrealTournament/UnrealTournamentEditor/UnrealTournament/Saved/Cooked/CTF-101v0011/WindowsNoEditor/UnrealTournament/Content/RestrictedAssets/Audio/Movers/Attenuation_Lifts.uasset
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-10.13.22:332]  0]LogSavePackage:Display: No exports found (or all exports are editor-only) for Attenuation_Lifts. Package will not be saved.

I’m able to build previous versions of this map.

Any idea what I should do? I’ve found both of those last two assets in my Content Browser, and I don’t think I’m using them…

Thanks,

M

Update:

I’ve deleted some asset folders that I wasn’t using, and have also fixed up redirectors in folders on a few other asset folders, including Restricted Assets. Now, the build properly fails. I have absolutely no idea what’s happening. Here’s the last bit of my output log:


LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-22.37.44:770]  0]LogMemory:Warning: Freeing 33554432 bytes from backup pool to handle out of memory.
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-22.37.44:770]  0]LogMemory:Warning: MemoryStats:
LogPackageContent: Publishing: UE4Editor-Cmd:  AvailablePhysical 944496640
LogPackageContent: Publishing: UE4Editor-Cmd:   AvailableVirtual 140730989068288
LogPackageContent: Publishing: UE4Editor-Cmd:       UsedPhysical 5772877824
LogPackageContent: Publishing: UE4Editor-Cmd:   PeakUsedPhysical 5773312000
LogPackageContent: Publishing: UE4Editor-Cmd:        UsedVirtual 5981802496
LogPackageContent: Publishing: UE4Editor-Cmd:    PeakUsedVirtual 5991718912
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-22.37.48:698]  0]LogOutputDevice:Error: 
LogPackageContent: Publishing: UE4Editor-Cmd: begin: stack for UAT
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-22.37.48:699]  0]LogWindows:Error: === Critical error: ===
LogPackageContent: Publishing: UE4Editor-Cmd: 
LogPackageContent: Publishing: UE4Editor-Cmd: Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-UT-Releases\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 143] 
LogPackageContent: Publishing: UE4Editor-Cmd: Ran out of memory allocating 9831724 bytes with alignment 0
LogPackageContent: Publishing: UE4Editor-Cmd: 
LogPackageContent: Publishing: UE4Editor-Cmd: 
LogPackageContent: Publishing: UE4Editor-Cmd: 
LogPackageContent: Publishing: UE4Editor-Cmd: 
LogPackageContent: Publishing: UE4Editor-Cmd: 
LogPackageContent: Publishing: UE4Editor-Cmd: 
LogPackageContent: Publishing: UE4Editor-Cmd: 
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-22.37.48:702]  0]LogOutputDevice:Error: 
LogPackageContent: Publishing: UE4Editor-Cmd: end: stack for UAT
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-22.37.48:786]  0]LogPhysics:Warning: PHYSX: ..\..\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined.
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-22.37.48:787]  0]LogPhysics:Warning: PHYSX: ..\..\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined.
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-22.37.48:788]  0]LogPhysics:Warning: PHYSX: ..\..\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined.
LogPackageContent: Publishing: UE4Editor-Cmd: [2016.09.09-22.37.48:789]  0]LogPhysics:Warning: PHYSX: ..\..\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined.
LogPackageContent: Publishing: CommandUtils.Run: Run: Took 189.1221519s to run UE4Editor-Cmd.exe, ExitCode=3
LogPackageContent: Publishing: Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: BUILD FAILED: Failed while running Cook for D:\UnrealTournament\UnrealTournamentEditor\UnrealTournament\UnrealTournament.uproject; see log D:\UnrealTournamen
LogPackageContent: Publishing: t\UnrealTournamentEditor\Engine\Programs\AutomationTool\Saved\Logs\Cook-2016.09.09-15.37.56.txt
LogPackageContent: Publishing:    at AutomationTool.CommandUtils.RunCommandlet(FileReference ProjectName, String UE4Exe, String Commandlet, String Parameters)
LogPackageContent: Publishing:    at UnrealTournamentGame.Automation.MakeUTDLC.ExecuteBuild()
LogPackageContent: Publishing:    at AutomationTool.BuildCommand.Execute()
LogPackageContent: Publishing:    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
LogPackageContent: Publishing:    at AutomationTool.Automation.Process(String] CommandLine)
LogPackageContent: Publishing:    at AutomationTool.Program.MainProc(Object Param)
LogPackageContent: Publishing:    at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
LogPackageContent: Publishing:    at AutomationTool.Program.Main()
LogPackageContent: Publishing: Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
LogPackageContent: Publishing: Domain_ProcessExit
LogPackageContent: Publishing: copying UAT log files...
LogPackageContent: Publishing: BUILD FAILED

Any ideas on what to do?

Here’s the cook:

Don’t delete stuff from outside the engine, only after you have deleted it from inside the engine you can do that safely.

While I did migrate an asset package to my Content folder through the Windows file explorer, I haven’t deleted anything from outside of the engine (I don’t think).

Still finding no luck, though.

Since I can build other levels in my Content folder that don’t use the imported asset package, can I safely rule out that this asset package is what’s causing the problem? I’m building an Unreal Tournament level and using the ‘SuperGrid Starter pack’. How can I know if an asset pack is compatible with Unreal Tournament? Or are all of them compatible?

Unfortunately they’re not all compatible.

Best thing to do is asking the Creator of the Pack, if he can check compatibility.

Yeah I figured… Thanks for the tip!