Build Failed when packaging project

No matter how a compile from source, either “Development” or “Development Editor”
this error comes up when I package my project both x86 and x64
I dont know if its my engine compiling problem, or its the way i package the project…

MainFrameActions: Packaging (Windows
(64-bit)):
InternalUtils.SafeFindFiles:
SafeFindFiles
C:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Binaries\Win64
CrashReportClient.exe True
MainFrameActions: Packaging (Windows
(64-bit)): InternalUtils.FindFiles:
FindFiles
C:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Binaries\Win64
CrashReportClient.exe True
MainFrameActions: Packaging (Windows
(64-bit)): ErrorReporter.Error: ERROR:
AutomationTool error: No files found
to deploy for
C:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Binaries\Win64
with wildcard CrashReportClient.exe
and exclusions MainFrameActions:
Packaging (Windows (64-bit)):
BuildCommand.Execute: ERROR: BUILD
FAILED MainFrameActions: Packaging
(Windows (64-bit)): Program.Main:
ERROR: AutomationTool terminated with
exception: MainFrameActions: Packaging
(Windows (64-bit)): Program.Main:
ERROR: Exception in AutomationTool: No
files found to deploy for
C:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Binaries\Win64
with wildcard CrashReportClient.exe
and exclusions MainFrameActions:
Packaging (Windows (64-bit)):
Stacktrace: at De MainFrameActions:
Packaging (Windows (64-bit)):
ploymentContext.StageFiles(StagedFileType
FileType, String InPath, String
Wildcard, Boolean bRecursive, String[]
ExcludeWildcard, String NewPath,
Boolean bAllowNone, Boolean bRemap,
String NewName) in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\DeploymentContext.cs:line
317 MainFrameActions: Packaging
(Windows (64-bit)): at
BaseWinPlatform.StageExecutable(String
Ext, DeploymentContext SC, String
InPath, String Wildcard, Boolean
bRecursive, String[] ExcludeWildcard,
String NewPath, Boolean bAllowNone,
StagedFileType InStageFileType, String
NewName) in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\Win\WinPlatform.Automation.cs:line
20 MainFrameActions: Packaging
(Windows (64-bit)): at
BaseWinPlatform.GetFilesToDeployOrStage(ProjectParams
Params, DeploymentContext SC) in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\Win\WinPlatform.Automation.cs:line
35 MainFrameActions: Packaging
(Windows (64-bit)): at
Project.CreateStagingManifest(ProjectParams
Params, DeploymentContext SC) in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\Scripts\CopyBuildToStagingDirectory.Automation.cs:line
159 MainFrameActions: Packaging
(Windows (64-bit)): at
Project.CopyBuildToStagingDirectory(ProjectParams
Params) in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\Scripts\CopyBuildToStagingDirectory.Automation.cs:line
1025 MainFrameActions: Packaging
(Windows (64-bit)): at
BuildCookRun.DoBuildCookRun(ProjectParams
Params) in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\Scripts\BuildCookRun.Automation.cs:line
251 MainFrameActions: Packaging
(Windows (64-bit)): at
BuildCommand.Execute() in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\BuildCommand.cs:line
37 MainFrameActions: Packaging
(Windows (64-bit)): at
AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands) in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\Automation.cs:line
371 MainFrameActions: Packaging
(Windows (64-bit)): at
AutomationTool.Automation.Process(String[]
CommandLine) in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\Automation.cs:line
343 MainFrameActions: Packaging
(Windows (64-bit)): at
AutomationTool.Program.MainProc(Object
Param) in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\Program.cs:line
166 MainFrameActions: Packaging
(Windows (64-bit)): at
AutomationTool.InternalUtils.RunSingleInstance(MainProc
Main, Object Param) in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\Utils.cs:line
649 MainFrameActions: Packaging
(Windows (64-bit)): at
AutomationTool.Program.Main() in
c:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Source\Programs\AutomationTool\Program.cs:line
113 MainFrameActions: Packaging
(Windows (64-bit)): Program.Main:
ERROR: No files found to deploy for
C:\Users\Joshua\Desktop\Installers\Unreal
Engine
4.5.1\UnrealEngine-4.5.1-release\Engine\Binaries\Win64
with wildcard CrashReportClient.exe
and exclusions MainFrameActions:
Packaging (Windows (64-bit)):
ProcessManager.KillAll: Trying to kill
0 spawned processes. MainFrameActions:
Packaging (Windows (64-bit)):
Program.Main: AutomationTool exiting
with ExitCode=30 MainFrameActions:
Packaging (Windows (64-bit)):
Domain_ProcessExit MainFrameActions:
Packaging (Windows (64-bit)):
ProcessManager.KillAll: Trying to kill
0 spawned processes. MainFrameActions:
Packaging (Windows (64-bit)):
AutomationToolLauncher exiting with
ExitCode=30 MainFrameActions:
Packaging (Windows (64-bit)): copying
UAT log files… MainFrameActions:
Packaging (Windows (64-bit)):
RunUAT.bat ERROR: AutomationTool was
unable to run successfully.
MainFrameActions: Packaging (Windows
(64-bit)): BUILD FAILED

Hey dmj0shu4,

Thanks you for reporting this issue. Here is a user that was seeing a similar error that you have been seeing. Here is a link to the issue: Packaging failed "No files found to deploy" - Platform & Builds - Unreal Engine Forums

It seems that the issue is being caused by not using Visual Studio 2013.

Please be sure to let me know if this helps with your issue.

Thanks and have a great day!