Build Failed on PC of UE 4.8

I tried to use the “Launch” button and project launcher, both of them gave me the same result.
BuildCommand.Execute: ERROR: BUILD FAILED
Program.Main: ERROR: AutomationTool terminated with exception:
Program.Main: ERROR: Exception in AutomationScripts.Automation: Missing receipt ‘’. Check that this target has been built.
The name of my level is “virtualdrivingtest” and I want to pack it on PC.
But every time I launch it, it failed.
I tried to launch some official demo, and they failed either.
I don’t know why and to be honest I don’t understand the error information.
Does anyone have idea? I am on 4.8 official not preview.
Thanks in advance

Hey Netseeker,

Could you please provide me the error and, or output that were given from the build failure? Also, are you able to build first person template from the engine without receiving these errors? Please provide me with your dxdiag as well, attach them with the other in your next response. :slight_smile:

Looking forward to hearing back from you, thanks!

Thank you for explaining what you ran into. Let us know if you have any further questions! :slight_smile:

Oh, I found my solution:
I realized that I installed Substance plugin for 4.8. But I remember I installed this plugin after I started my level.
Then I uninstalled the Substance plugin from engine. And I tried to open my project, it says this project uses Substance plugin but I don’t have it. But I didn’t use it on this one, so I chose NO for not install the plugin from market.
Then I opened my level and launch it, it was successful. It confuses me and I still don’t know why.
But here is my advice: Do check any plugin you have installed, those may cause some problems for some reason.

Thanks, but I have found the problem although I don’t understand it. Also, here is my a little feedback. Even though I don’t know why, I am pretty sure the problem is about that plugin. I remember when I use 4.3 and 4.7, I launched 2 projects successfully. And when I started to use 4.8, I found Substance plugin is on the market, as a Substance Designer , I immediately installed the plugin. Then today I tried to build my project, it failed. and after I uninstalled the plugin, everything worked. So please check with guys at Substance, there may be something in the plugin that interfere with UE.

Hi ,

I once had C++ sources but now I am Blueprint-only, deleted the module from the .uproject file, recreated the VS project files, rebuilt the engine but still can’t package:

Missing receipt ‘’. Check that this target has been built.

Is there any place in the project besides the .uproject file where all the needed modules are listed (which isn’t affect if you recreate the VS-project files for the engine)?


This issue that you are describing is different than what’s listed on this AnswerHub post. Please submit a new AnswerHub and provide all of the information that you can regarding your Visual Studio complications.