Download

(Bug v4.23) Crash to desktop whenever I'm adding more than one Grass Output Type

I’m creating my landscape material. I have 4 layers on it. I have created a grass output type for my grass layer and connected it to that layer, working fine. Now in my grassoutput node I click + to add another grass (that goes well) BUT when I select to add the second grass type (which I created earlier by duplicating my already existing one in the asset browser) I get a crash. I tried a few different things and can’t get this to work. I’ve seen this bug mentioned a few times around the forums and reportedly it’s been fixed since v4.9? I don’t think so… I also tried another suggestion which was to set all texture samplers to ‘shared:wrap’ to no avail. Has anybody faced this issue and can suggest a workaround, or something to get past this roadblock I’m at right now? (note that updating to v4.24 is not an option, nor a solution for me, right now). I have reported this bug a couple of days ago, with the UE4 error reporter which comes up every time I get the CTD, but they haven’t responded yet. I thought of mentioning this here as well, in case somebody can help. By the way, I’m on Windows 8.1 x64, NVidia RTX GPU, i7 CPU. Thank you.

Ok they responded me and told me to update. I updated from v4.23 to v4.23.1 and this solved the problem.

Know that your post here has assisted at least one individual, namely me. Thank you!

If I remember correctly, and if anyone else stumbles here who is having the issue the work around was to create all the grass type files first, delete the existing grass node, and create a new one by adding pins and linking the existing files all in one go before saving the shader.