[Bug(?)]:Stationary spot lights don't lit "larger objects" after build

This seems strange and I’m not sure if this is a bug or I’m doing something wrong here.
In beta6 stationary light seem to stop to lit “larger” objects after I build the lighting.

Issue can be reproduced easily:

  • in beta6 go to File, New Level, choose “Primitives” level
  • now disable or delete the default directional light
  • create a spot light and pull it up a bit above the ground, and place it so that it lights the primitives and also the ground
  • build the lighting
  • after applying the new lighting, light should stop lighting the ground (but still lights the primitives)

Some oddities:

  • point lights seem to work as expected
  • if you scale down the ground mesh to 0.4/0.4/0.4, it will start to work as expected
  • if you move the light it again starts to lit the ground (which I guess is actually ok as it probably switches to dynamically lighting the scene until rebuild is done again)

Hi Tomas,

Thank you for your question. I am investigating this issue on Rocket Beta 6, but I am having some difficulty. We have used the steps you have provided and we’re seeing that the ground is dimly lit. Here is our result after building lighting.

Could you please provide us with a screen shot of the rendering issue you have found so we can compare results. Make sure to include the Details panel for your light so we can compare properties values too. We are using a default Spot Light.

Thanks

Hello.
Strange, I couldn’t reproduce the bug in a new map. I’m sure when I was posting the bug that I tried to reproduce it as in my description and I also tried to restart Rocket and reproduced it again.

At least I can still reproduce the bug in my map. I have attached an image and also stripped down map where you just have to rebuild the lighting to see the “bug”.

[link text][2]

Thank you for providing us this additional information and assets. We were able to use the assets provided to reproduce the issue you have experienced. However, we were able to determine the issue is with the static mesh itself and that maybe indicative of incorrect export settings when creating the fbx from your modeling software. If you like you can send us the fbx and we will try to investigate it further.

Hello, I have attached the fbx file. It would be great if you would let me know what’s wrong with it so that I can avoid it.

A few more notes:

  • export was done in 3dsmax 2014
  • I tried to use v2013 exporter and also v2014 (which gives warning on import in UE, but otherwise seem to work same way as 2013)
  • fbx plugin version is 2014.0.1 (209164)
  • I’m 99% sure (was 100% before you told me it’s my mesh that’s causing the problem :slight_smile: ) I was able to replicate the bug in the default Rocket map (File/New Level => Primitives) and that the problem disappeared if I scaled the ground object to 0.4
  • I tried importing normals and also let UE recalculate normals (no difference with this particular problem)

And here is the fbx exporter settings I’m using:

[link text][2]

Hi Tomas,

Thank you for the FBX asset. I was able to export your mesh again using the default options in my 3d modeling software and the spot lights work for it now on my machine. I am not able to completely narrow down the cause as it most likely has to do with the custom exporting options set in 3Dsmax. Please let us know if you require any further assistance with debugging.

Cheers!

Alexander

Thanks Alexander. When this is not a Rocket issue but one in the exporter I will try to figure out the reason. If I find it, I will post here for future reference.