Download

Bug? Or am I doing something wrong?

Im using a Line Trace by Channel to spawn a simple emitter. When shooting at an NPC you can see that the trace is hitting the Collision Capsule even thought I have set the Trace response of both nodes to ignore. It is the same with overlap. Is this a bug or am I missing something? I want it to only hit the mesh, which it does if I get the barrel of the gun past the collision capsule.


I may try to recreate this in a different project.

Tried to test it in a different project and came back with the same results.

Try using the nodes ‘Set Collision Response To channel’ and ‘Set Collision Profile Name’ off of begin play. If the first node alone doesn’t work, you may need to call the second node first, and pass ‘Custom’ for the new name.

Something like this, but again, I can’t remember if you need the profile name node.

You may also try creating a new collision trace channel, to be found in project settings…

Perfect!!! Thank you so much! Yea it didnt need the profile name, I just needed to set the mesh to block with that same node. I actually have an even bigger issue now haha. It deals with making that AI crouch. I have Can Crouch enabled and when I set up an instance where in a separate blueprint I make “is crouched” true and false. It prints the string as you can see but doesn’t change the capsule which is the main thing I need it to do. On event begin play and event tick with just the crouch node it changes it but not when I set up a branch and test for true and false on that variable. This seems more like a bug to me.


What is your crouched half height?

If it’s the same as your capsule half height, your capsule will not shrink.

Its the same as default. Was editing my post recently. It will change to the capsule half height when I dont set a branch to it.

If you take out the collision nodes I specified, does the crouching work as intended?

No. This was happening before you gave me the solution of the collision nodes. My main problem before posting was that when the AI crouches the capsule is still the same height. I was going to do a work around with setting the line trace to pass through the capsule but I still need the capsule to change regardless if the line trace can go through.

I thought that fix may have caused the problem. Ah well.

That does seem like a bug to me.

Great… Well thanks for your help. This may have been fixed in later versions of the engine as I am working in 4.8 so I may try to test it again.

P.S. I like the look of Ethos, good work.

Thanks for having a look. There will be more to show soon™ :cool: