Download

Bug Detected in 4.13

Yesterday I copied my project from 4.12 to 4.13 version and I think I found a bug. Basically I made a physics handle gun to grab physics body which are detected by a line trace. In 4.12 when my trace hit a specific actor (an AI character) this one ragdolize so that I can grab the actor and move him around. When this actor hit the ground he should start to get up and while he’s getting up I can STILL grab him and move him around (obviously stopping his animation and setting his physics to 1 (ragdoll)).In 4.13 I can do the same things but when I execute a blend weight for pelvis and below bones while he’s getting up to make the transition from ragdoll to animated smooth a strange thing happen: my line trace (the same that should check for grabbable objects) doesn’t recognize the AI character anymore but just goes through him BUT it still hits some bones of the character but in a weird way because when he starts to get up I can grab for example his feet to make him ragdoll again and stop the animation but If I wait some more when he’s almost standing the trace hits only his pelvis.I also noticed that the bones inside the collision capsule can’t be grabbed, no matter when I try to do it. I tried to fix this problem all the day but I failed so at this point I think this is a bug and I’m posting this here (i’ll do the same on answerhub)because on 4.12 version it’s all ok and I’m going mad because I really need some features on 4.13 version. I think the problem is the physics blend weight node because If I remove this interpolation and make my BP to change directly the physics alpha from 1 (ragdoll) to 0 when he starts to get up I can grab him any moment and without any bug, so probably somehow the blending I made is bugging all my project.

To reproduce it I suggest to make a simple physics handle gun and a pawn that goes ragdoll when hit by the line trace and that goes up again with physics alpha interpolation for a blending effect. I hope Epic sees this or someone that knows If I can bypass this :confused:

if you think you’ve found a bug in one of the engine versions, then you should take a look here:
https://www.unrealengine.com/support/report-a-bug

then here:
https://answers.unrealengine.com/questions/ask.html

4.14.* is already out, 4.15.* in public testing phase. - Maybe you want to check out if it’s already fixed there.
If not, see the previous post.

Ok when I arrive at Home I’ll take a look at that anyway I have already tried 4.14 and there is the same problem seems like they changed something in how line trace recognize physics body because I also found that the mesh parts inside the collision capsule have no collision so the trace won’t see them…Thanks for the answers anyway

ok I posted a bug report on answerhub and seems that I finally found what the problem is:
basically if you add to SK_Mannequin’s root a capsule and set physics blend between 1 and 0 you can’t grab (ctrl+RMB) the upper parts of the body (head,arms and torso) but only the calfs. If you remove it you can only interact with torso and sometimes with other parts of the body but usually the only responsive part of the body is the torso. In 4.12 I tried to do the same things and this doesn’t happen so I think this is a new feature (i would like to know the sense of it lol ) or just a bug. So this explain why I can’t grab some parts of the body of my mesh while getting up using physics handle.

And yes this is still there in 4.14 but I still didn’t try 4.15 preview yet.