BP pins disconnecting on restarting UE4

After finally getting my project opening after converting to 4.6 I’ve found that some pins win disconnect themselves whenever I restart UE4.

an example is here: http://i.imgur.com/sQzqZ8c.png

The PostProcessComponent is on the actor. It’s not a variable. The set enabled pins no longer recognise a PostProcessComponent as the target but instead want a “Reference”.

Please, make sure that you’re using the latest version of PR 682, especially commit 5f8f9d. First one was buggy and lead to behavior you describe here.

I am using the latest. Sadly it’s still happening.

It only happens with the Character movement component and the post process component as far as i can tell.

I’ll try to fix it on Monday. Would be great if you could create a minimal project that reproduces the bug.

Random additional questions:

  1. Does detaching also happen to nodes that you created after applying PR 892?

  2. Does detaching happen to functions nodes and/or variable nodes?

  1. yes If i recreate the nodes and apply the same methods i get the same detaching.
  2. function nodes. It either seems to think the target of the function is the tpye of blueprint the event graph is on (if that blueprint has a function name that fits) or the target is “Reference” type.

I created a test project with similar blueprint as on your screenshot. And it works correctly on 4.6 + commit 5f8f9d, without any pin disconnects. Please, also check it and if you get pin disconnects on this minimal project, it means you haven’t applied PR 682 properly.

On the other side, if this project works correctly for you but you still get pin disconnects in your real project, I need your help with reproducing this bug (because in my real project I don’t encounter such problems).

Honestly I spent too long trying to get my project working in the first place. I don’t really have time to test this. I’m sorry.

Hi ,

There is a known issue in which some variables were broken when moved from 4.5 to 4.6. Try creating a new copy of the variable and plug that into the nodes. Please let me know if, after replacing your variables, this compiles correctly (note: you may have to remove the old, broken variables from the event graph).

Creating entirely new copies of the components results in the same disconnection. Even after removing the old.

I’ll be honest I’m now having troubles opening my project in 4.5 getting

Fatal error!

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff

when opening my player object.

Is there any way I can send you my project so I can work out what I am doing wrong in my program structure or what exactly is going on. I’m a bit exhausted trying all these different little fixes when I really just want to work on making a game.

Hi ,

Absolutely, if you upload it to a trusted FTP server, such as dropbox and post the link here I’ll be sure to take a look.

Here’s a link to a text document with the file and the changes I’ve made.

Hey -

I tried to reproduce this bug in 4.6 and in a 4.5 project that i copied into 4.6 without success. In which blueprint are you using the post process component? Is the blueprint asset set in the level already? Also let me know if you’re able to reproduce this in a new project and what steps you took if you can.


The Player Blueprint under Game/Blueprints/Player. It should already exist in defaultLevel. I’ve not been able to reproduce this in a new project. I’m currently considering converting all I have to c++ so I don’t have to deal with this hassle every time I try to convert (I went through something similar in 4.3-4.4).

Hey -

When I tried to open the Player blueprint, the editor crashed immediately. The same thing happened with a number of other blueprints as well. I have submitted this crash as well as the original issue with the BP pins becoming disconnected(UE-7110) for further investigation by our engineers.