Both Packaged project and VR Preview show black screen in Oculus Rift after upgrading from 4.11 to 4.13.1

Hi there,

I’ve been experiencing Oculus Rift CV1 “black screen” (nothing showing in Oculus) after migrating project from 4.11 to 4.13.1, the project was originally built in 4.9, back then it wouldn’t run on CV1 and migrating from 4.9 to 4.11 solved the issue, but now it’s happening again - maybe due to a different cause but can’t seem to find anyone with a similar problem.

Both VR preview in editor and packaged project will not show any visuals in Oculus Rift CV1, after hitting alt+enter it just goes black, I can hear sound but no visuals.

Please help.

Many thanks

Hello phantommoth,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints/settings that may be involved with this issue?

Hi Rudy,

thank you for your reply, sorry for the delay on responding to you.

I’ve been flat-out at the office so haven’t got chance to try and reproduce the problem using a clean 4.11 project and upgrading it to 4.13.

I did notice something strange after I sent my packaged project to one of my colleagues, for some reason he was able to open it in Rift using “stereo on” command in console, by the way the usual “alt+enter” doesn’t work on both my and his machine, only the “Stereo on” command was able to launch the packaged project onto Rift on his machine only, I suspect that the problem maybe that my machine is slightly older and for some reason the Rift doesn’t like the USB 3.0 ports on my machine, so I was forced to use USB 2.0, which I had no problems when running the older project in 4.11, the issue only started to happen after the 4.13 upgrade.

Will try and give you more info next week (we are in New Zealand so we are a day ahead US)


The change you mentioned about Alt+Enter not entering VR mode is working as intended. I believe this change was implemented in 4.12. Currently the only way to enter VR mode outside the editor is by launching with -vr, “stereo on” in console, or by code. I hope that this information helps.

Hi Rudy, I have built a project using the new VR template, and in editor the oculus runs perfectly, but as soon as its built the oculus remains as a black screen. Can you explain how to launch VR mode outside of the editor, as typing stereo on into the console doesnt seem to work.



When you say that the screen is black, is this while wearing the headset or are you going off of what the window on the monitor looks like. If it is the latter of the two, could you try putting on your headset and make sure that oculus home is not waiting for you to give UE4 permission to use the headset?

Thanks for the reply Rudy, it was showing black even with the oculus on (sensor covered). I managed to get it working by adding an event begin play > console command ‘-vr’ . Hope this helps someone

Thanks for your reply


Thanks for the info Rudy, that clears up the mystery, will do further tests once I’m able to run the project on a different machine with newer USB 3.0 ports.

Cheers :slight_smile:

I was getting a black screen on oculus only, worked fine. It turns out that the problem was caused by Enable Auto Loading Splash Screen, which is an oculus plugin function that is supposed to show their custom splash screen when loading. It was making the screen black and I couldn’t see anything. After removing it, everything worked fine.

Where does one add such event? “adding an event begin play”

Where did you find it?

You set it with blueprints, or at least that is how I did it in 2017.