Bones show in position of parents when imported from Blender

When I export characters from Blender, then import into UE4, the bones from the characters show up in the position of its parent bones. Here’s a minimal example I setup to show the problem:

As you can see, there are 4 bones in Blender, only 3 show up in UE4. At first it seems like “bone4” isn’t showing. But in reality it is where its parent “bone3” should be. And so fourth, until the first bone, “bone1” has no size. I can still select and rotate each bone and they seem to deform fine. But I’m having some problems in my animations that I cannot debug properly in UE4 because of this problem of the bones not showing in their correct positions. If I turn on “add leaf bones” in the export settings, then I can see the position of “bone4”, but only because one additional unnecessary bone is created.

Is there any way to fix that?

[I’ve uploaded that simple .blend file here.][2] It was created with Blender 2.79b, exported with the settings saved on that file. And imported into an empty UE4.21 project with default settings.