Download

Blurry Static Mesh

Hello!
I’m poking around in U4, trying to import some of my stuff from UDK3 and I’ve noticed an odd issue.
When I view a static mesh in the editor, it looks fine, but after building and playing in-game it’s blurry when you look down at the object!
It’s probably caused by a setting somewhere, but I’m really at a loss at the moment.

Blur_issue.jpg

Any thoughts on what I could try to force it to be as sharp as it is when I view the object in the editor?

Thanks!

Might be Temporal Anti-Aliasing which is on by default and blurs the scene a lot.
You would need to add a PostProcess Volume to your scene (possibly check ‘Unbound’ so it’s affecting the whole level) and then change the AA type to FXAA or None.

If it’s just a single mesh looking blurry it’s probably a MipMap issue, although the texture would get less blurry as you get closer to the object.

That did the trick, thanks!

The temporal AA in UE4 works similar to if you have super sampling on. Like super-sampling and SGSSAA, the way to adjust for sharpness with temporal AA in UE4 is to adjust your mip bias. This can be done as follows in UE4 from the command line,

r.MipMapLODBias -1

Which sets a -1.0 bias (sharper). Set the following to get no bias (the current default),

r.MipMapLODBias 0

Any floating point number works. Numbers more negative than -1 tend to not have any effect (because the texture streamer likely didn’t bring that mip level in).

If that is not good enough, there is also another option which effects the size of the filtering kernel in temporal AA,

r.TemporalAASharpness 1

Which can increase sharpness (0 is the default). Any number between 0 and 1 works here. This option reduces the amount of anti-aliasing (so makes the image sharper, but with more aliasing).