BluePrint Corrupted, Crash when opening Project

link textlink text

Hello, I Have Been Working on a small project Based on BluePrint, When a BluePrint (ResistanceWeapon) stopped compiling whitout any changes to it or to any other blueprint related. Without saving i closed the project and reopened it.
Unfortunately All my BluePrint Related to ResistanceWeapon, and ResistanceWeapon itself were now Corrupted. At this point, Start Playing or Right/Left Clicking any of those corrupted BluePrint in the Content Browser made the editor crash.

I Tried Setting bRecompileOnLoad to False in BaseEngine.ini but my BluePrints were still uneditable.

I then tried many things. Creating a new project and Importing old backups of my blueprints with bRecompileOnLoad to false gave me the chance to edit them. But they couldn’t compile, Some of the Variables i made appeared in the graph but couldn’t be found in my Variables list. I Deleted those variables in the graph, but when trying to create new ones with the same Name, the Editor told me i couldn’t because a Variables with the same name already existed.

After Deleting all parts of the BluePrint that communicated with other blueprints, i then recompiled it and those “Ghost” variable still weren’t appearing, couldn’t be found with the search tool, but the Editor still told me they existed when trying to create new ones.

So i Created a brand new project Extending on the ThirdPerson BP. Created brand New BluePrints, And Remade the hole project based on some Copy-Past and Remaking some stuff.
There i Encountered a new minor problem. Input Command inside my BluePrints extending actor did not respond anymore. I just went around this problem by Puting Inputs Inside “MyCharacter” BluePrint and making them communicate with the blueprint extending from Actor.

At This Point all my Project was back and running. All worked perfectly fine. While remaking this new project i exited the editor multiple times and got the time to manually make a backup of the project from the document Folder.

The next day (Today) i Turn on the computer, and open my project. Editor instantly Crashes. I open the manual Backup i made, Same Thing. I Try Removing “ResistanceWeapon” Project opens (but obviously dont compile due to references to ResistanceWeapon of other blueprints)

I Linked the .uproject and all the Blueprint I Modified or Created from the project from the save i made yesterday when everything were working like a Charm after Copy/Pasting, Recreating everything.
When Crashing the editor always display nothing else than : “We apologize for the inconvenience.
Please send this crash report to help improve our software.”

plz…Help me…

*Edited, with Log of current Crash and DxDiag

Hi Talus,

Could you please post your Dxdiag and also the log files that were generated at the time of the crash? The log filess can be located in the [Project Name]/Saved/Logs. That will allow us to further investigate the issue.

Cheers!

+1 Happened to me as well
link text
and log fileslink text

Build: GITHUB 4.0.1-0+UE4

I could also include the assets in question

Would you mind providing the assets in question? Unfortunately, there’s not a lot to go on in the log!

link text

Here they are I think…
They seemed to get corrupt when i was updating the blueprint interface they implemented and i think i may have deleted it or something??? not 100% sure, i just know i was messing with interfaces.

Hi joessu -

I tried opening those assets, but they don’t appear to have valid package signatures. Were you using a modified version of the engine? If they’re simple enough, can you paste screens of what was in them so we might get some leads? Thanks!

ugh… unfortunately i can’t reproduce it!!! (i did update)
I just tried one of the backups that was during the time i was having issues, it said during launch of editor “couldnt find blueprint blah blah” but i opened it and saved and compiled it just fine. i have a ton of backups from the time stuff was generating the error. between noon and 4pm on sunday. i attached a zip of the remaining backups during that time. you can see that i was mucking with interface stuff. i put the zip on my dropbox because it was too big.dropbox zip

The engine i was using was just a vanilla github compile

Just to point out we’ve had the same issue and had to redo 1 day of work.

My colleague is having the same issue problem asset. this is definitely a file that is failing.

He reached this problem by his computer crashing, and then rebooting.

Unreal said that it could not load blueprint because it couldn’t find parent class, but the parent class exists, we did a recompile to make sure.

Hi joessu -

Unfortunately all the MyCharacter and TeleporterBallProjectile backups here have to same issues that the prior zip had… You say it works now? Have you since recreated the work you were doing? Or did you do something different? The files are definitely borked, it’d be nice to have a hint of what lead to this (it is unfortunately hard to reverse engineer the cause). If you’ve recreated the work (to the best of your recollection), then could you provide us some screens of your current graphs? This could hopefully give us some leads to follow.

Thanks! - MikeB

Well, the hexgrid.zip file in the comments above cannot open (causes crash). It was caused when the computer it was on crashed. i guess the unreal process was flatout killed while the blueprint was open? (at least in that particular case)

With that asset, it looks like there was a “Break” struct node and the associated struct type can not be found (maybe it was deleted)? Regardless, this should not crash. I just fixed the crash issue, so that should be resolved with some update in the future.

However, once you make it passed the crash, the asset is like the rest. Do you maybe not have the struct defined that your colleague was using (and this is why it’s crashing for you)? Does your colleague have any information on the crash that seems to have caused this? What exactly was he/she doing? What are the specs of the machine that he/she is on? I assume that since it rebooted the machine, that he/she didn’t get a chance to report the crash through our reporter tool?

At the very least, thanks for helping us resolve the break-struct crash! This will for sure help others down the road.

Dude the blueprint stuff is awesome, if i knew the source better i would take a stab at debugging it myself!
We were compiling the game code when the computer crashed (it actually overheated haha stupid skype screen share), and i’m not sure how far along the compile was, since we were watching VS do it’s thing then boom black screen.

In both cases, the blueprints inherited from custom code classes!

Is there any way that you can provide us with those native code files, so that we can try and load it with those classes (we can’t load them without the parent classes)? What might have happened is if you ever got rid of the code classes (renamed them, etc.), then somehow saved the blueprint, it could have saved out with a null parent class. Even if you bring the old base class back, the association has been lost.

lemme know which folder you want, the sources folder? It was just a prototype/learning project so i don’t mind sharing the whole thing really.

The files that contained the custom code classes that the blueprints in question inherited from. - Thanks!

[link text][1]

here are all the sources
[1]: 2942-sidescrollertest.zip (5.15 KB)

Hi Talus,

Was “ResistanceProj” a class that you had defined and maybe removed or renamed? Or maybe you didn’t include it in the .zip that you provided us?

I did find and fix a crash, but it looks like it resulted from not being able to find a class type that used to exist (specifically regarding the “PM_Slot” variable).

Either way, thanks for identifying this crash. Users should be able to remove/rename classes without hitting a crash.

Cheers - MikeB

Hi Mike, I did have a “ResistanceProj” blueprint, but all assets that are still there are present in the .zip file. I don’t remember if ResistanceProj got deleted or if it was a Rename. Anyway, i am now on 4.0.2 and i never reencountered this bug again.

Awesome! Glad to hear it!