Blender to Unreal FBX scale is broken for my project

Unreal is importing all of my Blender static meshes extremely small (it seems like they’re at .01 scale). I am using the same Blender scene units and export settings that I’ve been using for years without issue.

Blender scene units:


Blender FBX export settings:


Unreal Import Settings:

I have tried:

  1. Setting Blender units to centimeters, or meters with a Unit Scale of 100

  2. Setting Scale to 100 in the FBX exporter

  3. Exporting from Blender 2.79 and Blender 2.80

  4. Enabling/disabling “Convert Scene” and “Convert Scene Units” on the importer

  5. Setting Import Uniform Scale to 100 on the importer

None of these changes have any effect – the meshes still come in at .01 scale. I’m actually quite surprised that not even cranking up the Uniform Scale makes a difference.

The same FBX imports without scale issues in a fresh 4.22.3 project. It only seems to affect my game (unfortunately I can’t upload the .uproject here because it’s proprietary and very large).

Any ideas what might be going on here? Unfortunately this is a huge blocker for my project. I’ve scoured the project settings to see if it might be something config related (this project has gone through many engine upgrades over the years) but haven’t spotted anything that seems relevant. Any help would be much appreciated. Thanks!

I managed to find a fix for this shortly after posting this question so I’m posting it here in case anyone runs into a similar problem. This appears to have been a cache issue. Deleting my Intermediate and Saved folders fixed it; my models import at the expected scale now using the same settings.