Download

Blender to 3ds max problem

Hi guys, :slight_smile:

I have a pretty annoying problem with my character that still appears (I had the same problem in the UE4 beta, but there I solved it). So basically the problem is:

"You can see it in the 2nd post, because somehow I’m not able to post 2 images into one thread"

As you can see on the picture that you can find in the 2nd post, the rigg and the mesh looks perfect -> so it has the right scale, but when I play one of the animations:

http://img5.fotos-hochladen.net/uploads/problem2o8cgm53wyl.png

the scale of the rigg jumps back to 1 and the mesh remains at 85.
**
My steps:**

  1. I created the whole character with animations
  2. As it is to small when I import it with a scale of 1, I had to scale the rigg and after that the mesh to 85. (I did that in the object mode and in the “reset position” mode)
  3. Now I just normally exported it
  4. After that I imported it with all the animations

That’s my workflow to get a skeletal mesh character into the UE4 -> it has worked in all beta version of the UE4.

So as you can see on the pictures, my problem is that the rigg in the animation doesn’t get scaled up, so it always remains at a scale of 1.

What we have already tried:

  1. Scaled the rigg in the pose mode
  2. made a new simple animation
  3. tried out some other different scaling techniques → e.g scale it in the pose mode + in object mode,…
  4. in the UE4 we changed the “Translation Retargeting”

We still try to find a solution for this problem, but somehow nothing really works. :frowning:

Somebody has any suggestions what could be wrong or how we can solve it?

Thank you for your answers

Philipp :slight_smile:

Here it is:

http://img5.fotos-hochladen.net/uploads/problem12ecrh1oy36.png

Have you tried to scale everything in Blender to “Metric” and then .01 This should give you centimeters. U4 is in cm. If you scale Blender to .1, it will be Meters in which case you simply have to do the math (might be better for your head). It does look as though there is a scale issue with one axis. Looking at your pics, I am feeling a matter of X/2.54 coming up.

Always always always apply scale in Blender before exporting.

Click your armature, Object > Apply > Scale, then do the same for the mesh. That should fix it.

OMG, how could I forget to do this… thank you, you are a genius! :wink:

Hey Sorry if this is irrelevant but i would like to PM / Private Message you its a surprise! (im sorry if this seems fishy dont worry its a big surprise!) also this helped alot!