Download

Bizarre display driver problems when loading the editor.

Okay, so I have no idea when this started to happen or why, but when I first was using Unreal Engine everything was fine; framerate in some levels was less than stellar but my harddrive was due for a reformatting. Anyway, after about a week or two, there were some strange green flickers every so often in my display. I thought that was just a bug with the rendering that would be patched up soon enough. But unfortunately that never happened, and now Unreal Engine has gotten to an unuseable state. To show what I mean, I recorded a video with my phone:

https://youtube.com/watch?v=Yk1boyaff_k
[EDIT] And if the video player isn’t working for whatever reason (tends to happen to me for some reason} here’s a direct link instead: http://www.youtube.com/watch?v=Yk1boyaff_k

As illustrated in the video, I enter the map, do absolutely nothing, and the graphics expodentially start to eat themselves until the entire editor just breaks down and my display driver kicks the bucket. Let it be known this didn’t happen initially when using UE4; this only happened within the last week.

For reference, my specs are as follows:
GPU: NVidia 660 GTX
CPU: Intel i7 (pre-sandybridge}
RAM: 3 2GB Kingston cards (6GB total… probably not enough? Should be}

DETAILED GPU INFORMATION:

I’m wondering if anyone has any idea what could be causing this, or how I can get to the source of the problem. Thanks!

-Chimera

The videos is in private mode :slight_smile: Do you get that green flickerin just in the UE4 or also in games?

fixed the private mode problem. The green flickering ONLY happens in Unreal Engine 4. And reacently I even updated my drivers to the beta and loaded up effects caves; there still is flickering and then my driver crashing.

It seems even when the camera’s moving this engine will just love to crash on me :x

Hmm, pretty strange, because when this flickering would also appear in games, then your gpu would be damaged. I would recommend you to download a tool which measures the temperature of your gpu, because probably this problem appears when it gets overheated.

That looks like a bug I’ve gotten in some games when my video drivers were out of date. If you haven’t already, update your drivers.

Points to a previous post…

Sometimes it helps to read the posts AFTER the first post in a thread :wink:

Hmm, ok from the video I can see something similar that I had. In my opinion it is definitely a bug, because when I have placed foliage into my level in the UE4 beta, I also got such strange shining stuff on my screen. Just post this into the answer hub :wink:

I did actually post this on the answers hub a long while ago: Bizarre display driver problems when loading the editor. - UE4 AnswerHub

Unfortunately I didn’t get much of an answer, and only one person replied who only ever answered one question before.

If it means anything I also found out my motherboard is specifically a Rampage III Formula.

I decided to downgrade my drivers to version 320.49 as a test; someone suggested I actually try /older/ versions of display drivers to see if anything wonky still happens or if the effects are the same. I’m also checking my GPU temp this time to see if it heats up significantly; not exactly a controlled experiment I know, but oh well.

The older drivers seemed to maintain stability for a longer time, however I found out something rather odd.
Surprisingly, what I found out was that my GPU temp actually /skyrocketed/ when I loaded up UE4. As in, not only did it go up but it went up a LOT. My max before loading UE4 was 37 deg Celcius, and it didn’t even reach that high when loading the map. Once the map WAS loaded, however, the temperature spiked to 45, then 50, and kept going up slowly but surely. The flickers started happening around the 56C ish range, getting worse as the temperature got hotter, and finally everything broke down when it hit 70C, probably a failsafe so the GPU doesn’t fry itself.

Good god, what could be causing this?! I thought I’d need to de-dust my PC but this is just ridiculous… It idles at 35 celcius which I’d think should be fine. Nothing else gets it this hot; why UE4?

EDIT: Tried forcing vsynch with nVIDIA control pannel. Doesn’t solve the problem; the GPU keeps heating up steadily.

Probably you dont have enough fans in your PC or he is at a place where the heat gets accumulated. Just open up the case of your pc and place it somewhere in your room, then try out what happens or you could also limit the max fps rate in the editor to around 35-40 → Can you lock the FPS? - UE4 AnswerHub Then you could also try to run a graphic card test → e.g Heaven Benchmark,…

I think the problem might be the dust. Heat gets /super/ accumulated because of it I’m sure. I’ll probably have a way to dedust tonight, so let’s just hope…

ever since ue4 has been out beta/public it will send your graphics card to full load, there was a blog about how to set the graphic options in the editor which helps lower the problem, you can also turn of a lot of the post processing but this will affect how things look

once you’ve de-dusted you need to check your cards settings to make sure it stays under the max temp

Definitely sounds like a temperature issue, I only have a 560Ti and I’m not running into any of this, but my case is fairly well ventilated and cooled touch wood.

You also have a HELLA lot of nVidia software installed, is all of that really necessary? I don’t think any of that runs on the card but that seems like a lot of background application going on. I’ve got purely the graphics driver and PhysX system software. Using the 331.82 drivers.