Download

Bizarre Audio Glitch with Unreal Engine 4 Games

Hello! Not sure if this is the correct place to post it but I figured I’d give it a shot.

I have a pretty high end PC (1080ti, i7 7700, 32 gigs of ram) which I purchased last year. I bought a Vive around a month ago. I have been playing a wide variety of VR games as a result. One of my recent favorites (In Death) has a strange audio glitch which produces pops and white noise as I play, though it is annoying, the sound is rather quiet and so I can ignore it. The game is in early access, I figured it might just be a bug they need to work out.

More recently I have purchased Rez Infinite and Adrift and noticed the same exact issue (though much more apparent and hard to ignore in these two titles) with audio popping, as well as louder, booming pops that sometimes echo. In Rez, the louder glitching noises only occur during the menu for whatever reason. Once I load into the game proper, the sound is fine (which is funny in a way because Rez’s audio is so audio glitch-based as it is). In Adrift, the noise is much less apparent like it is in In Death, though it is far more annoying and impossible to ignore.

I began looking for connections between these three games, as well as doing everything in my power to solve this issue. I have reinstalled Windows, Steam, all of these games, and audio and display drivers. I have experimented with different audio setups in VR as well as through my desktop, using both HDMI and Display Port connectors, and still the same problem. Rez is playable on a desktop, so I tried it there and interestingly I get the exact same issue, so I think I can rule out the glitch having anything to do with my Vive.

I began to think it was a problem with my GPU or motherboard or some other hardware connection, but it only happens in these games, and other demanding games I’ve played (I’ve played a lot of Assassin’s Creed Origins and Evil Within 2 recently) never have this issue.

Finally, I realized that Rez Infinite’s new mode was made using Unreal Engine 4, and then I realized that both Adrift and In Death were also made in UE4. So then I tried another VR title made in UE4 (Portal Stories: VR) and wouldn’t you know it, I get the exact same audio glitch in the menus when I fire that game up. So then I think I found some sort of weird glitch concerning the UE4 engine.

As a final test, I purchased and downloaded Robo Recall (a more recent UE game) using the robo revive mod to allow me to play it through the Vive, and that game plays flawlessly, without any audio glitches at all. I am trying to figure out whether Robo Recall uses UE4 or a newer version of the UE engine but my quick search leaves me unsure, so either my problem is exclusively with UE4, or it is somehow connected to UE games I play in the Steam interface (since I believe Robo revive goes around using Steam entirely? But possibly this isn’t true either).

Anyway, here is an example of the audio for Rez. Make sure to lower the volume on your speakers before viewing. Notice how the sound is awful for the menu, but once I am in game that goes away and everything sounds fine.

https://www.youtube.com/watch?v=cGlDaY8qSuU&feature=youtu.be

Has anyone ever heard of this issue before? I have done some searching online and found no mention of this exact problem anywhere else. And maybe I’m completely off base with my assumption this has anything to do with the Unreal Engine, but like I said, I have played 30+ games in the last month since I began playing around with my Vive and these games were the only instances where this problem has cropped up. Thanks to anyone who’s taken the time to read!

Robo Recall is made by Epic with UE4, so if it’s not happening there, then it’s something with the developer of the other games that they need to fix.

It could have something to do with the audio code. Every game that got released before 4.16, uses old audio code which has some quirks. RoboRecall uses the 4.16 audio code I believe.

Interesting, thank you both for the replies. I have made a post on the discussion board for Rez on Steam in hopes I could find someone else who might be familiar with the issue, and I’ll try and reach out to the developers of other games where I’m experiencing the problem as well. I’ll also do some reading up on audio code changes in 4.16!

The biggest culprit at the moment is State of Decay 2. I’m playing that on Xbox One X whilst using party chat, and every so often the game produces a really loud hiss noise, which is really quite… horrific. You lose all game sound after each hiss. You can restart the sound by dropping to the Xbox dashboard and then re-entering the game (presumably coming back from this state restarts the audio engine).
We’ve almost stopped playing the game a couple of times because of it, it’s that bad. Once it starts happening it also reoccurs much more frequently, anything from 10 seconds to a few minutes, dependent on what the player is doing; driving a vehicle for example seems to exacerbate the problem.

They have just released a patch which states that they “may” have helped to fix it, (“4.1” I think), but we played it last night and the issue is still there. They describe it in the patch notes as “hard to track down”, but it’s happening so frequently for us I’m surprised Microsoft let it come out of test and the game released when it did.
Lots of people have been and still are complaining about it on the State of Decay 2 forums. If I were Epic I’d investigate this and then put the info out there to developers on how to fix it. It makes the engine an actual turn off for players at the moment, rather than something to marvel at.