Download

Birds

Hello.
But what about birds that are already in the sky? I’m going to make a short video of birds suddenly started to fly over some trees (scared by a gunshot, for example). I put them flying close enough to the trees, and the result is good for me. All I need is to make them wait before starting to fly away.

Hey I’ve just bought the pack and working on getting it set up but I’m having trouble getting the BirdEnemy behaveour working…
I have

  • migrated the birds folder to my proj
  • placed nav mesh into the scene
  • placed a crow
  • place a ground, perch and air target for the birds
  • added the BirdEnemy line inside the mannequin blueprints
  • hit play

which in theory is what your instructions say to do but they dont react with one another? do I have to add a collision in the mannequin blueprint? or have I just missed something?
Its worth noting I’ve done all this in a completely fresh scene so there shouldnt be anything bugging it.

First you will need more than one ground and sky target and they should be at least 2000 unreal units apart.
I’m guessing your new scene is just the default scene, witch is too small- give the Birds more space to move around. Also did you build navigation? other than that you did everything you need to. Double check that you put the BirdEnemy tag in the mannequin blueprint in the Actor Tag section. You can also test with the “NPCBot_WithEnemyTags” in this folder–> Birds\ThirdPersonBP\Blueprints
What are the Birds doing? are they moving around the scene? standing still? I’m trying to narrow down your issue.
I’m sure its just a little thing, and no its not collision in the mannequin blueprint.
Let me know if any of these suggestions fixed your issue, or if you are still having the issue give me more information.
We’ll get you up and running :slight_smile:

Hey, thanks for a quick reply!

I’ve done your suggestions and its now partly working! I think I’ve narrowed down the issue to the birds that are spawned on the ground. I suspect their “avoid” behavior just doesnt kick in until they choose to start walking around the scene? I’ve got a clip here I can share to clarify the issue
https://www.youtube.com/watch?v=pycY…ature=youtu.be

Also just a thought… would it be possible for you to do a write up on how I’d go about adding my own mesh / anims and such into this system you’ve got? I’d like to update the meshes a little so they fit as well as possible to the look of the game we’re developing

Thanks for the video, very helpful. I can see exactly whats happening here. The issue is that those birds that start out the level on the ground need to be set to “Begin the Level Walking”.By default the Birds are set to begin the level flying and they should be placed up in the air when set this way. So the birds are trying to fly but they are getting stuck on the ground, they also don’t fly away from you because enemy avoidance is disabled while flying. so to fix- select all the Birds on the ground, Then over in the details panel uncheck the Bool - “BeginLevelFlying?” and check “BeginLevelWalking”. In this same way you can get the Birds to begin the level perched as well. Also be sure that only one of the Begin Level (Walking, Flying, Perched) Bools are set to true. Otherwise the Birds will get confused.

Also you can swap out the skeletal mesh with your own. you will need to create a new animation blueprint for your new mesh. Just use the existing animation blueprint as your guide.
I hope that was helpful, keep me posted. :slight_smile:

cheers! this fixed the issue! I’ll add a post when I’ve worked out adding a new skeletal mesh with my updated birds :wink:

I was excited to see that the upcoming game “The Shore” is using Birds. The Seagulls made it into the trailer in a few shots. Very cool!
In the first trailer, in the shot with the light house- you can see the Birds obstacle avoidance working beautifully.
The Seagull flies up and over the light house.

Trailer #1

https://www.youtube.com/watch?v=-RQfkZU_4c4

Trailer #2
https://youtube.com/watch?v=dgqUmNm4akM
The Shore is developed by Ares Dragonis and will be released on 02/19/2021 on Steam.
I cant wait to check it out!

Just bought the asset and I’m excited to get it working. How do I go about starting? I’ve dragged the Bird_Perch_TargetPoint and Bird_Sky_TargetPoint into my scene. I then dragged the BP_NPC_Pigeon into my scene and turned on the “Begin level perched” option. The bird starts perched for about 1 second and then it tried to fly but then just falls straight down in the Z direction.

How can I get the bird to start perched and then fly into the air? Do you have any tutorials? Do I need to manually change parameters for each bird that I want to make fly away? Or is there a flocking system?

Thanks!

my guess is you have everything too close together, You should have at least 2 sky targets at least 3000 unreal units apart, and at least 2 ground targets as well. Have a navmesh volume in place and build navigation. take a look at the demo level, there are many birds that start out the level perched on top of the tutorial wall.
Make sure the begin level perched Bool is true and the other two are false. you can set this per bird added to your level, or you can set it in the blueprint for all the Birds in the parent class.

Take a look at the Behavior Tree ( “Bird_BT” )
In the BehaviorTree you can set how long the Birds will perch. (See attached image)

](filedata/fetch?id=1874461&d=1616709511)
Birds doesn’t currently have a flocking system.

Hope that was helpful

Thanks for the quick response. Unfortunately this doesn’t solve the issue. I deleted birds out of my project > merged new birds project with my working project > placed and resized new “navmeshboundsvolume” and then went step by step in the video below. If you watch it can you see if I’m missing any steps?

https://www.youtube.com/watch?v=l48iTip1TPU

looks like a good setup to me and those targets are plenty far apart.
not sure why the bird is falling through the world though. do you have collision enabled on the ground?
Does it work ok when you have the bird begin the level flying? Or walking?
Does that sign have collision? You may need to add a small collision volume for the bird to stand on. Perched birds still respect gravity.
Trying to narrow down your issue. I’m sure its just some little thing.

I added a blocking volume and that worked. Thank you. Now I’ve got to figure out how to get it working within the sequencer.

Hello I just implemented the bird pack in my level. I added the sky ground and perch targets. in the beginning all seems good they perch and fly but then the crows get stuck in mid air and not doing anything anymore. It seems most of them fly to the ground target and get stuck there. They hover above it and stay rhere also they dont land. After that I also see some of them stuck in random places… I dont get any errors or anything and I rebuilded the navigation. Also I would like to set them up to only fly and perch and not to go to ground targets and walk. How do i make that happen? I only see the option for stay in sky not to disable walking.

This may be because the Birds have the wrong starting conditions. For example if a Bird is set to begin the level flying then that bird needs to be up in the air, not down on the ground. when you drag a Bird into your level you can set begin the level walking, flying or perched in its default settings. only one should be true.

This is very easy to do. you need to go to the Tasks folder (Birds > ParentClassBlueprints > Tasks)
open the “BTTask_Bird_RandomBehaviorSelector”
and (see attached image) for adjustment


then save and compile.

Thank you for the answer. changing that value was what I was looking for. Strange that the birds get stuck though I had all the settings you mentioned right. Could it have to do with collisions?

It definitely can be collision . Try raising how high the sky targets are and be more selective about your perch points. test with few at first to see what is causing your issues.