Behaviour tree REINST bug

Hello, I’ve got quite a strange bug in our game that’s a little difficult to explain.

Some of our enemy behaviour tree’s have stopped working. If I look at the tree then it’ll show either of these two things depending on my actions before checking the tree. Either the broken nodes will show red like this

and hovering over them will say the class is missing.

Or the broken nodes will display like this

If I delete and re-add the nodes then the tree works again until I close the editor. When I open the editor and play the game the tree will break again (unless I look at the tree in the editor before attempting to play the game, weirdly)

Not every behaviour tree is doing this (but it is most of my behaviour trees) and I can’t see any obvious difference between those that work and those that do not.

Some other things to mention;

  • If I try and view the tree during gameplay to debug then the editor hard crashes. If I pause gameplay first I can open the tree but the debug dropdown doesn’t find any instances of the tree to view and clicking resume again hard crashes the editor.
  • I can’t say for sure what version this originally occurred on. I noticed it on 4.17 and have since upgraded to 4.18 but as i’ve been working on other aspects of the game it could have happened as early as 4.15/4.16. That said one of the enemies I was working on worked fine in 4.17 until it suddenly started doing this as well but I can’t see any relation that might have caused this.

So far i’ve tried remaking the behaviour tree and remaking the individual tasks but it still failed in the same way.

I don’t think I can reasonably reproduce this in a clean project since it’s in a game of 2+ years development and I can’t find the difference between the working behaviour trees and the ones that break.

Any help I can get on this would be greatly appreciated.

All the best,



We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.