Download

Beginner messing around

I’ve read an Epic’s dev saying in one of the topics that it would be helpful for them to now where beginner struggle in order to improve the documentation. So here I am to tell you what’s going on for me trying to figure out this kludge. maybe I can also have some help in the mean time.
I decided to start from scratch and my first objective was to have a camera, a box, and have an input to move the box (which is still not yet working after 2 days).

First, I created a project from “basic code template”. before clicking I tried to make sure that I shouldn’t use blanck project instead and therefore search on internet some precision about what this “basic code” include, I never got a clue before actually creating the new project.
Once this supposed empty project is created, I click play and realise I have a moving camera. from that come few hours trying to open everyblueprint and browsing the created code to try to figure out where is implemented this camera movement. now I think it’s internal to the engine if I don’t have any playerController setup, but still not sure.
So I create a pawn blueprint, I put inside a cube and my movements nodes and a camera, click start again, my camera is not used, instead it seam that my pawn instanciate it’s own camera at his position, and nothing move.
After few hours of searching again I finally come up with:
c952bce3e1dda9f92109807e4a4acd52a1fa3347.jpeg
now my camera is used, but I think my pawn continue to magicaly instanciate a FPS camera as if I click sur “simulate” then “posses”, I still get into that camera instead of the one I’ve setup.

Finally I’m now trying to move my pawn, I came up with this simple nodes:
movement.jpg
but nothing move, I multiplayed the value by 100, displayed on screen the axis value and debuged the nodes, the event is correctly fired and the axis value is correct, I have no clue why it’s not moving.
movement2.jpg
the tooltip talks about applying acceleration, but I haven’t found any information about this yet, other people don’t seems to deal with that.

Already more than 10 hours searching around. I think the more annoying think with this engine for beginner would be the question “Where the hell is the code/blueprint that cause this behaviour ? Why isn’t just nothing hapenning ?” which come up for everything.

edit: finally got something moving:
47d44f3eb5f5187a165b8b5e9357ca70d7f80ff8.jpeg
about “Add movement Input”, It seems to need a “Pawn Movement Component” but didn’t find any information about that.