Download

Baking m_med_nrw_ to Control rig distorts MH? (UE 4.27.2)

Baking to ControlRig (body) in Sequencer seems to result in distortion of MH? (UE 4.27.2)

To reproduce…

  • Use a m_med_nrw (Ettore) MH in Unreal 4.27.2
  • Make new Seq and add MH
  • Set a Key Frame on the first frame (MH can be in original “A” pose or anything else)
  • Bake To Animation Sequence
  • Delete Control Rig Track and +Track to add animation track selecting the new anim seq
    (MH will “pop” up in size. Set “Retarget Source” of Anim Seq to m_med_nrw… to restore proper size, save changes)
  • Bake to Control Rig
    MH will pop up in size again.

Is there a step or setting that I’m missing to ensure baking to control rig maintains proper control/joint arrangement?
(I’m guessing this, or something similar, will happen to any MH that is not the base f_med_nrw size?)

Hey did you have any luck with solving this, I haven’t had issues with this before but seems with the new update it’s causing the issues, can’t figure it out?

No reply yet. Thanks for checking.
Trying to reach out for help through a few different channels, but I’m sure folks are still just getting back in and up to speed after the end-of-year break.

For what it’s worth, I had an older (pre-0.5.0) MH with the same skeleton size (m_med_nrw) and baking to control rig works fine with him. Also, the “Bake To Control Rig” options window that opens before the bake has a smaller set of options, so it’s looking like something new in 0.5.0 introduced this.

Will certainly post here if a solution emerges from other channels.

Hey I found that if you open the body mesh and change the skeleton retageting options that are associated with it then it will fix the issue. Watch this video, forget the first part you want from about 3:50, this has fixed it for me, you only need to do it once then it’s fine every time you bake to control rig.

thats-me-jinx

Yeah… I’m Pixel Prof on YouTube.
Glad you liked the tutorial. :slight_smile:

Changing those skeleton options (which isn’t actually recommended as an “ideal” solution as it defeats the functionality of the leaf joints in the rig which preserve limb volume during bends) helps for animation sequences. Unfortunately, even with this cheat used, the distortion issue still happens with bake-to-control-rig.

Ah I’ll check again, I’m pretty sure that’s what solved the issue for me. I remembered seeing your video and thought I’d try that. Do you know if there is any actual resolve for the issue or is it just a bug with the current MH?

I have no solid info either way at the moment. It could very well be that there’s a option or setting somewhere that I’m just not using. Will certainly share any info here as it turns up. :slight_smile:

1 Like