Baked static light dark areas.


I’m trying to bake static directional lighting onto my scene.
The bake itself looks good but some areas are darker than others.

I’ve set my skylight to intensity 2 and I still have black areas.
I fiddled around in the world settings as well.
There I changed the indirect lighting quality to 4 and smoothness to 0.75

Other then that I just increased the cliff models light map resolution scale from 64 to 512.
Below you can see a screen shot of the affected areas.