Download

Baked shadow appears like there's no lightmap

Hey guys,
I discovered a problem with lightmass in my scene.
The problem is that some of the floor meshes are baking shadows exactly as they should, while others, even though it’s the exact same mesh instance look like they are not having a lightmap.
They are brighter/darker according to how far they are from the light source but the shadowmap isn’t really creating a smooth shadow. The whole mesh is just darker.
A little hard to explain but I guess you can see it in the image well enough.
All floor meshes should have the same settings but the problem still occurs on a few of them, any ideas?

aa43a2d0a2715d43145f3d67af1f0380d0094ec9.jpeg

Make sure that your lightmap resolution is high enough. Some things can be attributed to how lightmass works–a mesh isn’t processed together so smoothing and sampling does not carry across meshes even if they’re supposed to appear to be a single object, so for your case since you’re using modular assets, the pieces are going to have slightly different lighting compared to each other. You can mess with the World lightmass settings to try and see how much you can improve it, but the issue won’t go away entirely. Smoothing and quality are the options that you want to adjust, lower the smoothing increase the quality.

I don’t think it’s a problem with lightmap resolution or quality as the problem only occurs on one paritcular part in the scene. Everywhere else it works just fine.
You can see it better here:
fd23e89f1c1772529719f4c43d751d547e189a7b.jpeg

Try to delete those meshes and replace them, also increase the number of bounces for lightmass and see if that helps.

Tried both but there’s no difference. Bounces were set to 3 but nothing changed with either 1 or 4

Put a light over there and test to see if it’s actually not receiving light or if it’s some kind of weird lighting anomaly.

Well, it works if I use a second light or move the existing light further to the left.
I think I should be able to fake it with a second light but I’d still be interested in what causes the actual problem