Bake lights at specific location

Hello, we are working on a small project for us and our friends, our playable map is 100x100x150, due to lack of funds for assets we duplicated the landscape 2 times, stretched it out and used it as background mountains in the distance. Now every time we are trying to build the light it would crash due to insufficient ram, (we run on 8gb).
Increased the page file on both SSDs to 30gb each and now it goes through but it took 11 hours to reach 50% and its still stuck there…
Increased Static Light to 2.0 in World settings,with the hopes it would reduce building times… decreased foliage shadow res and disabled it completely for some, and it still takes this long.
Is it possible that the 2 extra landscapes in the background are causing this? If yes is it possible to ignore them when building light and only bake the playable area?
Or any other tip would be extremely helpfull. Thanks in advance.

i5 3770k
Asus Sabertooth Z77
Corsair Vengece 8b 1600
x2 SSD OCZ Vertex 120g
HD 7770
750w Corsair PSU
Windows 7 x64
UE 4.7

Hi iDivider,

You can disable Static Lighting for the Landscape by selecting it in your scene while in Placement mode. In the Details panel you will see a checkbox under Lighting and disable Static Shadow.

Also, make sure you’re using a Lightmass Importance Volume around your area that you want to be statically lit and is playable. This way anything outside of that volume will only get a single bounce from any static lighting that is needed.

I hope this helps.