Bad #include in IImageWrapperModule.h

Build Type: Binary

Build version: Version: 4.15.0-3299760+++UE4+Release-4.15

Detailed description of the issue: There is an include in the Runtime/ImageWrapper/public/interfaces/IImageWrapperModule.h file that has an invalid path. Specifically,

 #include "interfaces/IImageWrapper.h"

should be:

 #include "IImageWrapper.h"

as the IImageWrapperModule.h and IImageWrapper.h files are both in the interfaces directory.

otherwise a compile error is thrown when attempting to package a project that references the ImageWrapper.h header, (or anything that includes the IImageWrapperModule)

Reproduce Steps:

  1. add source to the project.

  2. add: #include “Runtime/ImageWrapper/Public/ImageWrapper.h”
    to a class

  3. attempt to package.

Ah, that makes a lot of sense. It’s embarrassing that I didn’t know that that’s the protocol.

Hi,

i think the include path is correct, as it is releative to the include directory of this module.

What you are probably missing is a "ImageWrapper" entry in your [project].Build.cs file. Add it to the PublicDependencyModuleNames. This entry adds the include path of the module to the list of include paths and, and thus the compiler should now be able to find the header file.

your include should then also be changed from #include "Runtime/ImageWrapper/Public/ImageWrapper.h" to #include "ImageWrapper.h"

Could you please accept the answer, if it solved your problem? Thanks!

I was trying to, but couldn’t find the option on the interface.