Augmented Reality for UE4


The DEMO version is only working on windows /macOS from the editor.

I have a fix camera and a white area front that (The area size is almost 50 cm) and a red point (2 mm) for send a position to me.
How much accuracy can i have ? Can i get 1 mm movement ?

there is admin p

I got this error when running ARSampleHarleyEXECUTABLE.

hi adam, i tried to get the mobile phone screen resolution a bit better, i tried 720,480. But the screen turns purple. Is that something familiar to you? i changed it the way you showed here (android)

And another question, i have great porblems to get this on my phone. Sometimes the export goes well 10 times, but then suddenly it goes wrong. The export is a succes, but the app wont start. And once this happends, there is no way to get this starting again on my phone. (uninstall-install. phone on, phone off,… etc) Sometimes resetten the whole phone can help it.

best regards robert


in the video you sow 2 objects in diferents markers in the same camera but on the proyect artoolkitadvance we can read one marker. how to read 2 diferent markers spawning 2 objects(meshes)

Are you sure the resolution you set is supported by your device ? Can you please try something like 640x480 or 800x600 ?


Try the simple demo, it has an example for tracking multiple markers.

thanks it works great right now. Seems again and again a problem with nexus phones. Tried it on a samsung and it looks very good.

Hey it works really good, also my own made nft markers. Now the final step,… Making new scenes on different markers. But man, your levelbp looks complicated. Whats the best practice to do this? Should i copy the bp and make new event ticks? I rather not do that, because too many of these ticks wont work on most phones. When i duplicate the one touch bp and make some other meshes inside, seems a good start. But the way the bp will show and hide i dont understand.

Is this a full implementation of ARToolKit, but in Unreal?
What I mean is, can I use all the features of ARToolKit with this plug-in? And are they all available in blueprints?

Black and White fiducial marker tracking, matrix markers, and NFT tracking are implemented for Windows / Mac / iOS / Android.

Check out the documentation for blueprint nodes:

I am glad it’s working now!

For multiple NFT markers, just edit the level blueprint and check all of your markers visibility with the get marker node in the tick function. Once a markers is visible use it’s vectors/rotations for tracking your camera or subject.

Hello, I bought a personal version of the plug-in, did not pack it out, there is no way to put other people’s cell phones? Do I have to buy a commercial version?


Personal version is working on cell phones (Android / iOS).

Please follow the steps described on the link below:

If you still have issues please get back to me with log files.

Hi Adam, thanks for the reply. I think i am almost there. Made my own markers. Copied the bp AR-actor_touch. Changed this BP a bit and referenced this to my new marker. Everything seems to work the way i did below. But somehow the original is not updating the location. So once the marker is detected, the scene stays in one location. Have you an idea whats going wrong?


I cannot see too much … Can you please send me a higher resolution version to ?

oh man i am getting really crazy :slight_smile: Spending hours and hours, but i dont get it running. It works a bit, but not good enough. Has anyone maybe a youtube/ walkthrough where he showes how you can use different markers for diiferent scenes? I can make my own NFTmarkers, i can make some Blueprints to show a mesh and connect this to that marker. But once i use more markers and scenes it goes wrong.
Simple i want this:
marker 1 >>> shows blueprint 1
marker 2 >>> shows blueprint 2
But when i copy the levelBP with the NFT markers, and change the NFT and the Blueprint it doenst work!

i am sorry, there i am again. Most other thinks are working right now. Very happy to get this almost done :slight_smile: But the final step is the package to an .APK. That’s not working. Do you know this is a commen problem?, and i miss a very easy step (i hope). I tried to package a fresh template of UE4 (mobile, thirst person), and that packages allright. (both ue4.18)
here is the log: