Download

Augmented Reality for UE4

Hi Adam!

We want to make an App that can show a AR Version of architectural floorplans on the printed page.

-Is it possible to make the AR App like a typical Game were you can load different floorplan 3D Data like a Level?
-or is it just possible to load all Data at once… that would make the app extremely big if you have 30 Floorplans for one Project and would make it to big for a cellphone app if i put in fully baked detailed stuff.

Our Idea is to use a QR code first to load the app and maybe to know wich floorplan this is.
Then we use the picture of the floorplan as NFT marker for tracking.

So it would be awesome if we load the app only first like a startscreen and then only the data needed for this specific floorplan.

is this possible ?`;)

Seeya, Daniel

Thank you Adam,
I want to know is it possible to get location and rotation of two or more markers ?

Yes, you can track more than one markers!

Thanks, i couldn’t find in your website tutorials, how i can do it?

Check out the level blueprint of the Simple example that comes with the plugin. (the one with UE chair). All you have to do is to use multiple GetMarker nodes to get the position and rotation of each markers. http://www.unreal4ar.com/get-marker/

You can test if a marker is on the screen by using the visible pin.

I think u should add the ability to rotate off the y & x axis too for the main source, was the first thing I added.

Really enjoying the plugin- bought a personal licence and it’s pretty intuitive.

Only issue I’m having it adding my own markers.
I’ve tried generating through Tarotaro. It generates “name.pat” files which I just rename to “patt.name”
They appear to be the same size as the included markers and opening them up in a text editor they seem to be the same format.

I added them to both the data folder with the other makers and added them to the list in blueprint.

However, when launching the app on my phone my custom markers don’t work!
Anyone have any luck adding their own markers? And if so, what was your process?

Thanks!

7491833183fce97ed63ca2c6b5de463213dcaae3.jpeg

I also use some other driver management, in this PC is able to identify the camera, in other computers are able to run, but I do not know why only my PC in this computer can not identify the camera ~???
Attached Images Attached Images

I just bought a personal license of the plugin and tried it in my windows laptop (windows 10). Unfortunately I always get the error “webcam init error”. I also get the error from windows demo (http://www.unreal4ar.com/demo-videos/). In order to solve the issue I made a loop to test different camera’s IDs (from 0 to 16) without any success. Any ideas?

Hi.

I had a similar problem and found out that my antivirus was blocking UE from accessing the camera. Disabling camera protection did the trick.
You could also try to start your camera in another program and see if it works.

Hi Adam!

I’ve tried your plugin with multiple custom testmarker but i can’t get it to work. If i write them in the “Markers” Enumeration and it recognizes just the first one in the list. Is this a bug or do i something wrong? I’m using UE 4.16.2 and the 1.8 Plugin with personal license. I’ve tested it in the “ARToolkit Simple” Scene. Sorry for my english.

Thanks in advance!

Is there a way to use a different marker size besides the default Hiro size provided? I know it’s possible with NFT Markers, but those are more complex. Just trying to use regular Markers set to 40mm.

This is currently possible with the Unity plugin which allows you to define the marker size. If it’s not possible with the Unreal ARToolkit plugin are there plans to do so AdamHorvath?

Hi xmak.

I have kaspersky and I did what you suggested but without any l luck, I still get the same error. I also try disabling the antivirus, and nothing.

Hello everyone. I bought the full commercial license and I wanted to congratulate you on your work. But I do have one issue which is,
on the first page of this forum and in the second video (the one with the motorcycle) we can see the motorcycle being scaled and rotated.
Can someone please tell me how this is being done. I can’t seem to find keyboard shortcuts or mouse controls to achieve this. Thanks in advance.

Hey Adam:

Thanks for the plugin! It is great. We have been using it for an android development and with the new Android version 7, I have noticed an issue specifically with the Google Pixel. The camera does not work on the Pixel, do you have any idea why?

EDIT and ANSWER:
The file path for the obb in the APL file needs to start with Android

“/Android/obb/”

Thanks!

how can I record whats on the users phone?

My problem is solved. I just moved the “WindowsNoEditor” folder to C:\ and executed .exe file with success. I also set camera id to 1 (default value).

Hi Emma,

I am glad to hear it is working now! Did you have any special characters in your project path ?

You may find the following links useful:

Android:

iOS:
https://drfone.wondershare.com/screen-recorder/free-screen-recorder-ios-10-9.html

It’s not supported but you can change it from source code.
In \Plugins\ARToolkitPlugin\Source\ARToolkitPlugin\Private\ARToolkitDevice.cpp search for patt_width variable. It is set to 80 by default. It is the size of the marker.