Download

Augmented Reality for UE4

Hello Adam,

I have a problem with calibrating my android tablet camera. I have installed an app on my tablett, and another one on my PC. So I can use my tablet as a webcam. So far so good.

I then use camera_calib.exe file for generating camera_para.dat file like it is described here:
http://www.daslhub.org/unlv/wiki/doku.php?id=nxt_ar_toolkit

I did it twice, but I am not happy with the result. All tracked marker (I took some squared control planes for checking) are 2D shifted against live camera stream.
Is there a way to edit camera_para.dat by hand ? Just to set a different “Point of Interest” or similar?
Calculated FOV seems to be ok, marker lines are parallel by any viewing angle but still not matching. (its 2D shifted)

There are other tools for generating camera_para.dat like described here:
http://www.hitl.washington.edu/artoolkit/documentation/usercalibration.htm#onestep

Is this older or newer? Or even more exact? I do not have any calib_dist.exe or calib_cparam.exe. Where can I download?

Do I even have to change some C++ lines or xml or whatever.
Of course, I can change camera yaw and pitch a little to compensate this shift in bluprint, but I would like to do a more proper calibration.

Thanks, Peter

Hi Adam, first of all thank you for creating a really well made AR plugin that works for Windows, most of them are Android/IOS only.
I have two questions:

  1. can I have 2 of the same type of markers on screen at once? For Examples 2 Hiros on screen.
  2. How do I set the Camera resolution to 1080p or 720p 30fps and have that setting save each time I play?

I am also really struggling to figure out how to get NFT markers working?
I’ve read through the doc, but it’s not very helpful in explaining how to actually test the Data set?

Thank you very much for your reply Adam.

I’ve been doing some tests with these 3 nodes you recommended. What I could find out was that the set threshold mode and set threshold nodes have to do only with marker recognition by the camera in terms of brights and darks for easy recognition (good to have that, very useful) and the set filter node has more to do with the jittering or vibration at positioning the 3D models in relation to the marker position, but I can’t seem to soften the vibration in any way. Is there any other solution I can try to improve the vibration problem? By the way, I cannot increase the size of the marker due to the nature of the project, it needs to be in a certain place and not larger than a certain size to work for the purpose I am pursuing. Do you have any other suggestions?

Thank you very much.

Hello,

  1. No, you have to use different markers.

  2. You can set everything at startup when the “Show PIN” checkbox is checked.
    Init | UNREAL4AR

My recommendation is to use only 4:3 resolutions like 800x600 or 960x720

  1. Please find all the required tools for creating NFT markers (genTexData.exe is located in the /bin folder)
    https://drive.google.com/open?id=1bY29IdFG-d5DNpuI-LZl9eJ9BtPGQGqM

To use the new NFT:

  • Put the generated files to Content/ARToolkit/DataNFT
  • Add the name of your marker to the MarkersNFT enumeration in the unreal editor.
  • Use this new name for the GetMarkersNFT node.

There should not be that much jitter, even with the default settings.

Check out this video:https://youtube.com/watch?v=9VyhCu1Qxxo

What is your framerate ?

Hi Adam, thank you for the reply.

  1. With the marker tracking if I have multiple of the same marker on screen, it bugs out and doesn’t display a model on either of the markers until I remove both from the view.
    Is there a way to track the first marker, and keep tracking the first marker if another of the same type is added to the view?

  2. This setting does not Save, and I have to go through the checkbox every time, which I do not want, I want to be able to set up the parameters once.
    How I can set web camera source parameters?

  • Resolution
  • FPS
  • Video Format
  • Color Space
  1. Thank you, I managed to get that working :slight_smile:

The current setup doesn’t allow that.

Camera settings are not exposed for blueprints.

In the source code ARToolkitDevice.cpp line 548

[FONT=courier new]config << “-devNum=” << devNum<<" -flipV ";

You can add other options after the “-flipV” argument according to the docs

Theoretically it should work, but I had no luck with my logitech webcam.

Hello All, I’m still struggling with this - everything is working fine except the people im showing this project to want the model stay on the market when I move away from it and not disappear. Any ideas?

Otherwise this plugin is fantastic!!!

hi i want to use this plugin with Intel realsense
so i need to recompile artoolkit library
which version of artoolkit is in your latest plugin??

ARToolkit 5.3

You can download from here:
https://drive.google.com/open?id=1bY…Zl9eJ9BtPGQGqM

Hi Adam
I have purchased your plugin and follow your steps to build a project from the sample .
when I start the project showing me this message
https://drive.google.com/open?id=1g8…kjZYkxxnq2DFNQ

can you please tell me how to fix this problem, thanks

Hi Salim,

You need to compile the plugin first.

Please check out the getting started guide:
http://ar.uplugins.com/getting-started-full-version/

  1. CREATING THE SAMPLE PROJECT
    To create the sample project follow the steps below: a. Windows

  2. Install Visual Studio 2015/17 – community editions are also working

  3. Launch unreal engine editor

  4. Create a new C++ code project without starter content

  5. Copy all files from SampleProject directory to your new project directory

  6. In UE4 editor File -> Refresh visual studio project (optional)

  7. Exit from unreal engine editor

  8. Launch your new project from epic launcher

  9. Click on rebuild missing DLLs when prompted

  10. Optional: Click on File -> Package project -> Windows -> Windows 64bit

Hi Adam
I have an AR project, are you available to work?
If so let’s chat on skype for more details " abosalim314".
Thanks

Hi Adam,
I did all the steps and get the same error!

hi adam,
i have a sam probleme of salim but in mac os.

Hello,

Please send me the log files to info@uplugins.com

Best Regards,
Adam

Hi Adam good day; I have the commercial version 1_16 for UE4_24.3, but when creating the project the editor gives me an error that the ARToolkitPlugin module is missing, it recommends rebuilt, but doing so gives me an error that it must be done manually but the truth I don’t know what I could do, I hope you can help me; Have a great day.

Hi - this looks like a great plugin - do you have a trial so we can verify the functionality is giving us what we want and do you have a version updated for 4.25 yet?

Hello David,

I don’t have a trial version but you can check out the executable demos on the link below:
http://ar.uplugins.com/demo-videos/

4.25 and 4.26 versions are on the way.

Hello,

waiting for your AR plugin for UE 4.26 …