Download

Audiokinetic Wwise UE4 Integration - any luck?

Anyone tried it?

I went through Audiokinetic’s instructions 2x now and ended up getting the same errors when trying to build.

error: LNK1881 cannot open input file ‘AkMP3Source.lib’

It seems the Win32_vc120 and x64_vc120 folders they want you to copy over from the Wwise installation don’t actually have a ‘AkMP3Source.lib’ file in them. I tried copying over the ones found in Win32_vc110 and x64_vc110 which makes the errors go away during the build but then when I try to launch the editor it says the XINPUT1_4.lib is missing.

Anyone else had any luck with this?

I haven’t tried as of yet, but at some point I was planning on looking into this, please let me know if you do end up having any success (Maybe release to the community as a plugin if you can). Otherwise once I get around to it, I’ll let you know if I have any success (Currently have no ETA on when I will have time to try though)

See if this helps: How can I resolve the error stating that XINPUT1_4.dll is missing? - UE4 AnswerHub

Hi,

A small bug found its way in Wwise 2013.2.7, and AkMp3Source is missing from the VS2013 libraries. This will be fixed in the upcomming 2013.2.8 release. In the meantime, you can contact us to get the missing library.

I have sent a message through your contact form. Thank you!