Audio ducking via amplitude?

Is there a simple way to duck audio based on amplitude in UE4? Currently it seems like the ducking is based on the sound cue’s length and not actual loudness. Many of our assets have baked in reverb. Because of the reverb the .wav files have tails that will cause UE4’s audio engine to continue ducking. Or if there is a way to set the duration of the duck. I know there is a fade in time setting but that doesn’t seem to resolve the issue with the tail.

Thanks for any suggestions!

Alas, for now there is no amplitude-based ducking. The duration setting was broken for a long time, but just got recently fixed again- it should be in the next UE4 release. Sometimes, if I really need a specific ducking duration, I’ll split my sound into two soundwaves- one that’s ‘dry’, and one that has the reverb tail, and set a passive soundmix to duck only when the ‘dry’ sound is active. That way the soundmix fades back up during the tail and sounds more natural. I’m using this method all over the place on Fortnite :).
Best-
Zak