Download

Attaching Actor to Player Character Changes Camera

I’m using the third person template from the starter content while I have been creating a blueprint for a gun (set up as an actor). Everything is functional except for the action of picking up the gun itself. When the actor spawns in, he must go to the collision box that determines if he is in range to grab it and press e to pick it up. Upon picking up the gun, the camera always reverts to one of two views.
1.) It appears to be in the gut of the player.
Gut.png
2.) It has somewhat of a third person view, but only when the mouse is in a few very specific spots. My controls also seem to be backwards when I do this. However, I am still able to shoot the gun.
weird view.png
I have tried a multitude of different functions, variables, meshes, etc. to make it work, but none have been successful in fixing the camera view. I have also tried having the blueprint for picking it up in the ThirdPersonCharacter, gun, and level blueprints. Below I have attached two examples of ways I attempted to pick up the gun without messing up the player’s camera. Also, it may be important to note that the third person character has a follow camera, but I have not figured out how to set the view back to this camera manually.
46a4b58cbb270a51598e3d0eeea415fd724eddef.png
ed546159a2d153482b91fcb99e6503257bbbd14d.png
If anyone has any ideas on how to pick the gun actor up, please let me know. Thank you in advance.

I am guessing this is because the camera boom has “do collision test” checked. Gun you pick up is probably sticking out of the back of the character where the boom is attached. It tests that it is colliding and tries to get between you and the mesh. You can either uncheck that box for now or set the collsion for the gun to something else, I think character mesh would work.

I think James is correct. You could just delete the collision on the gun if you don’t need it, or just disable collision on the gun entirely when you want. (aka when you pick it up)

That worked perfectly. Thank you!