Download

Async Task Download Image does not work on OSX or wrong URL Format

Hello,

I bumped into a problem when I tried to make my windows app run also on OSX.
On windows the app runs well. Compiling on Mac was successful and the app runs generally, but:
I use the Async Task Download Image Blueprint node which takes a URL path as input.
On windows I found the right URL format to make it work.
Adding a “file:///” to the windows file path gives the right input for the Node in windows.
Now on Mac it was not working with the same URL Format so I tried all I could find in the internet,
first of course on the apple webpage. I am not sure if it is the format which is wrong because I tried so many combinations.
Maybe the Node is not running like it is running on windows.

So if anybody had a similar problem about URL Format or the function of the Async Task Download Image I would love to hear from it.

Best regards, Stefan

Best way to do this is to drag the image onto a chrome browser and get the URL from that.

Hi. Thank you for your help!
I was doing so and found out that my URL was right.
Also I realized that the blueprint node “Async Task Download Image” is not giving output
on success or fail so I think the function itself is not working on the OSX operating system.

I will write this to Unreal Engine development team.

Best regards and thanks again, Stefan