Assets not rendering properly with Quixel Bridge

Hi everyone!

I tried few days ago to import some Quixel assets with Quixel Bridge directly on Unreal Engine 4.7
I installed the Quixel plugin on UE4 and I’ve downloaded some 3d assets in 2K.
When I import them, the quality is very bad. For example, for small rocks, there are no details like reliefs, cavities or imperfections. These rocks have a plane surface which isn’t realist.

Is it because of the quality of the asset? Should I download the assets in 4K or 8K or there’s a setting which can fix it?
Thank you ! (sorry if there are some spelling mistakes, i’m not english)