Download

ASCII Post Process Material

Featured_IMG.jpg

ASCII POST PROCESS MATERIAL
Watch video of ASCII material in action

Marketplace link: https://www.unrealengine.com/marketp…ocess-material
Description:
This post process material turns any scene into ASCII art. Comes with 5 pre-built instance material variations, and allows for easy customization.

NEW IN VERSION 1.2:

  • Per object coloring! Use material RGB color to drive ASCII color.

Features:

  • 5 pre-built material instance presets
  • Customizeable parameters to change ASCII size, colors, and shapes
  • 2 pre-made ASCII texture atlases to use in the materials.

Texture Resolutions:

  • 1 - 1024x32 32 character “text” texture atlas
  • 1 - 256x32 8 character “dot” texture atlas

**Supported Development Platforms: **Windows
Supported Target Build Platforms: 4.15+

My ASCII post process material was just approved for release. If you try it out, let me know. I’d be happy to answer any questions about the asset. Thanks!

There was a question on reddit about how it works in VR. It works (surprisingly). I’ve uploaded a video preview of it in action in VR: https://www.youtube.com/watch?v=jJMRr5jH7k8

Update v1.2 is live: Now supports per object coloring!

Hi!
Any hint how to edit the material to use it only on one object? I would like to achieve “MI_ASCII_POC” material effect only on one object on scene.
Please help! :slight_smile:

@golus666 - It’s a fairly simple change to get this to work per object:

  1. Make sure your project is setup to use custom depth buffers. Make sure Project Settings->Rendering->Postprocessing->Custom Depth-Stencil Pass is set to Enabled
  2. Open the M_ASCII_MasterPerObjectColoring material up and add some nodes to the material. I’ve attached an image showing the setup.
  3. For any object you want to render with this post process material, set the mesh’s Rendering->Render CustomDepth Pass to true. Note that this can be dynamically turned on and off in blueprints as well.

Your MI_ASCII_POC post process material should now render only the objects you mark with the “Render CustomDepth Pass” attribute.

Hello! It still works fine on 4.22 without changes?

Hi
I tried to do what is shown in the image from @golus666 answer and it works but it makes the remaining of the screen (but the target actor) darker
How can I fix this?

Thanks in advance

@engelmanna I bought the asset, but when I add the volumes to my level, everything is black

What could cause this? Thanks