Download

Artefacts in Light Bake that i cannot fix :( HELP!!

I have done a lot of research into this and have tried everything i can think of so let me run down the list of things i have done and tried.

A. Custom light map that has been snapped to a 64 x 64 uv grid.

B. Separated the back faces that will be receiving no light/or darker light from the front faces. To A. further reduce light bleeds and b save on light map res

C. Maxed out light mass settings

D. Did a production build

E. Turned AO off.

Im at my wits end and i have a client deadline fast approaching any help will do!! Thank you so much in advance.

For some reason its not letting me upload any pictures

https://drive.google.com/drive/folders/0B_5mhoG8UqCYOG8wTVh5ZkxhTmc?usp=sharing

Here is a link to some images Please Help!!

Seems like a light map resolution problem. Select the problematic mesh, then ctrl+E and on the right side there is a tab “Static Mesh Settings”. On Light Map Resolution change the value to something like 512 or 1024.
:slight_smile:

You can’t have any surfaces on the outside of the walls, so the top of the wall or the bottom of the wall or whatever needs to be removed. Otherwise, they can bleed onto visible areas. They don’t add anything anyway, though adding a surface facing outwards for the outside wall can help if you are using a skylight and directional light.

The Back faces are already all removed anyway?

Not talking about back facing, I mean around the edges

Ok, did you changed the light map resolution and rebuild the light? Because I can see in your whole scene that doesnt have any small detail shadows. To troubleshoot lightmap resolution problems click the following keyshortcut ctrl+0 (zero) and if most of the maps are blue so you have low resolution which leads to artifacts.

Thanks for your feedback!

I had the walls in a blueprint and i realised that although i had overwritten the light map resolution inside the blueprint actor I hadn’t overwritten the resolution within the object itself in the content browser. Once i had done that it worked like a charm. I had assumed the two were linked? Apparently not?