Download

Are splines broken?

When I jump to the terrain and go to spline tools, then ctrl and click on an area, nothing happens…

Are splines broken in 4.7?

Anybody know if this is the case?

Are you talking about spline actors/components or landscape splines? Because I’ve been using the former without issue.

Landscape - I have a tiled mesh which I imported in 4.6 then updated to 4.7 (because tiled I.ports are broken in 4.7)

When I click manage terrain, then select the spleen tool, nothing happens when I ctrl and click on the terrain…

Can anyone shed any light on this please?

Hey Leam, I’ve checked landscape splines in 4.7.2 and mine works correctly.
Try to create new project and repeat spline creation - if it does work, your issue may be connected to the same problem, as creation tiled landscape in 4.7 and you should report it!

Hi Leam,

I’m not seeing this on my end as well. Is this project specific on your end or happening with any project you use.

Just to clarify my steps, which I assume are the same for you:

  • Create Landscape
  • Go to Manage > Then use drop down and select Edit Splines
  • Ctrl + LMB to place a control point

Works fine when I create a standard terrain - doesn’t work with an imported tilemap :frowning:

Yep, I am using that exact set of steps Tim. Hmmm :open_mouth:

This is definitely not working on a tiled landscape import, when you hit ctrl + lmb, the cursor just flashes and nothing happens.

Is this expected behavior for this type of terrain?

I find it hard to believe noone else is having this issue. Anyone?

Works fine on my tiled landscapes in 4.7.3

my cursor just blinks when I try to do it on 4.6 and 4.7 :confused:

Is there something I need to do to enable it on a tiled landscape? It works immediately on a standard terrain… But not on tiled imports…

Splines are not broken just because some functionality has not been setup yet. Up to this point Splines have only worked with single landscapes and not tiles. This was requested a while back with UE-6383 and it looks like this has been recently submitted feature with CL-2489554 to be included with 4.8.

I’ve not tried the feature since it’s only been in a few days, and I have no documentation at this given moment to go on either. It looks like the feature is coming though it may be 4.8 or later. I’m not sure what full functionality this will have, the limitations, nor if it’ll be listed as experimental starting out.

I hope this helps.

Okay, cool, thanks for the input Tim!

In the meantime, what if I scrap my tiled landscape, create various smaller ones that I can import as single files, then use splines on them and break the world up using level streaming?

Splines will only work with their individual landscape at the moment. Even using multiple landscapes generated in UE rather than the WM tiles will still result in the same behavior.

The only alternative at the moment would be to use Blueprint Splines, but these require more setup.

Okay, cool… Do blueprint splines also altar the terrain like a terrain spline would?

No they don’t. That functionality is with landscape splines only.