Download

Are ART tools causing a bug with rotations tangents?

A couple of weeks ago while working in Maya 2013 with the ART tool I started to get rotation keys with no tangents.
I made no changes or keyboard changes. The rotation tangents just disappeared.

I had Maya 2013 reinstalled and the ART tool then reinstalled. It worked fine until today.

While working with a character rig which was created in the ART tool the rotation keys just stopped showing tangents.

I tried to disconnect the ART tool from both perforce which is where it is kept. And I also removed anything related to the tool in the My documents folder on my computer.
I am still getting the prompt window on start up of “Maya looking for the Maya tools directory.” This tells me that somewhere Maya is still searching for a part of the ART tool.

Has anyone else run into this no tangents on rotation keys problem?

Any info would be appreciated.

Just to follow up.

I was able to disconnect the userSetup.py. I no longer get the prompt “Maya looking for the Maya tools directory.”
Maya 2013 still does not show rotation tangents. Reinstalling it again is a possibility but there is something not right.
There is a problem and I am just wondering if there is a connection to the ART tool.

Second follow up.

I went into the preferences of Maya and made sure that rotation interpolation was set to Independent Euler angle curves.
The ART tools are not as yet hooked back up. I restarted and did a simple animation test
and I now have the tangents for rotation.
I am not able to explain why I had this problem, Twice… I do not know why the problem is no longer there.
I will setup the ART tool again and see what happens.

If anyone has had this happen to them, I would like to know how you fixed it.

Hello!

I have seen this issue and I have the fix for you!
Check out the video :

Let me know if that solves it!
Cheers!