ARcore packaging for Android Fails

I have been trying for a couple of weeks now to package the HanheldAR project to my Android device with very little success. I have followed several tutorials in the process of setting up my sdk’s/ndk’s etc and have tried a variety of settings to package the project but also, no luck. I can successfully package an Android project but as soon as ARcore is enabled I encounter this error

I have read conflicting information as to whether ARcore needs its own additional NDK’s to successfully compile a project and I am wondering if this is the case. I am currently using Engine version 4.23 which uses ARcore version 1.7 and packaging to a Motorola G7.
Below is my full log of my most recent build attempt. Any information or assistance on this would be HIGHLY appreciated.

Thanks
Chris

[link text][2]