Download

[ArchVis] My first ArchVis in UE4 | Noob Questions

Hey Guys,

I am currently working on my first ArchVis in UE4.

Here is my blockout so far ->

b9405a2185862ddb5e608bea8c008f2bd485d901.png

I kept everything aligned to the grid to have a better time after the import in UE4.

I was wondering what is the best practice with a modular piece like this?

Do I have to combine the different parts together to have one big mesh (at least for every side of the building)?

Because I heard there could be problems with light leaking. But if I have big meshes I need bigger lightmaps :confused:

And what about intersecting. My modular peaces align perfectly on top of each other on the grid. Do I need to let them overlapp and intersect everywhere to avoid light baking errors and leaking?

Best Regards
FNGST

Its gonna be a bit of a trade-off for combining objects; in my experience, the more walls you have combined the less light leaking you will have.
But this will also mean that need a really, really big lightmap to cover all the walls, floors and ceilings.
A good workaround for this is to have seperate objects for the walls, ceilings and floors and have them intersect like you said.
You can then close off all the edges and corners of the scene by using simple black boxes to further prevent light leaks. A good example of this is the berlin apartment which you can download on the UE4 market for free.

Thank you so much for your answer! I will download the berlin demo and have a look! I will keep you updated on my progress :slight_smile:

I modeled a new scene and I am in the process of lighting it now…

Here are some screenshots:

0d2195850ea937b86cf5bef9b874b45315679d7a.jpeg
6163001bc226319e864269ddeeabe0904753da1c.jpeg
facfa8d07569386fe4586dc7689e4d4c790e7954.jpeg

I am using UE4.11 Preview and have set a light portal in every window (are the portals direction depended… meaning are they having a back and a front?) …

Those are my settings with what the screenshots were made… I baked on medium quality

1979c832782510efa2ebe8cb1d83aae94fc92c70.jpeg
0b5c1112d2b640a6eaa6d711ac6f9b9ff3793ad4.jpeg

I have every object at a lightmap resolution of 256…

I only used a skysphere with an hdri and a skylight using this hdri…

a27e09a99f78eff68849bd88a6d7cefea8c48663.jpeg

The thing is… when I have the skylight intensity at 1… it is very dark… probably because the windows are to small? To get the lighting from the screenshots I had to set the intensity of the skylight to 20…

How can I get a more even and nice lighting?

Also is the only way to get bright burned out windows (and not see the hdri through it) by placing emmissive white planes in front of the windows?

Thanks for help! :slight_smile:

looking good, try increasing indirect lighting of skylight. Assign 1024 lightmap res to large surfaces like floor, walls, bed cover.

As far as I know you can use a HDRI for your skylight but you don’t have t use this also for the SkySphere. You can use a sphere and give it a white slightly self illuminated material.

Do you have all your light sources set to static?