App Stuck at Installing after Updating Provisioning Profile

Today I added a few more devices for testing purposes and updated my provisioning profile. After changing to the new profile, my development app now stuck at installing.

Here is what I did:

  1. Added new devices UDID to iOS devices on Apple Developer

  2. Updated my development provisioning profile to include all the new devices

  3. Downloaded the new provisioning profile

  4. Imported the new provisioning profile with iPhonePackager.exe

  5. Imported the cert I used previously for the profile

  6. Press ready to package

  7. Launch my project with Unreal 4.9

  8. Package it for iOS (Development)

  9. Manually import the .ipa file to iTunes Library

  10. Install the .ipa to my device through iTunes Library

After step 10, my app is stuck at installing (Worked previously before updating provisioning profile). I rechecked all devices UDID and made sure it matches with the profile I am using. I am totally out of ideas now, any help would be appreciated. Thanks!

Silly me. I was not using the wildcard identifier as I needed to test various online features on iOS and used the same identifier for both development and distribution.

This has been solved by creating a new identifier and assigning it to the distribution provisioning profile. And finally reimporting all profiles and certs into unreal engine.

P.S. This will not affect you if you are using wildcard identifier