Download

App overwrites previos app when loaded to ipad or itunes???

I’m building a few apps in developer mode and installing them on an iPad, either by the Launch drop down menu or by packaging the project to iOS and installing via iTunes. I’m using Unreal Engine 4.5.1 and I’ve named each differently in the bundle name and have even tried separate bundle identifiers using different Apple ID’s. There are no problems getting each onto the iPad but as soon as i try for a second one on it overwrites the first. When I try to load the second into iTunes it prompts me with a warning that it is
“an older (or newer, depending on what app I’m trying) version of the app. ‘App Name’ already exists in your iTunes Library. Are you sure you want to replace it with the one you are moving”.
This is despite all the apps having different names and some even being built with different appID’s and developer certificates/mobileprovisions. What is the identifier that I’m missing that makes iTunes think they are all the same?
Any help much appreciated, been troubleshooting this for days but i’ve got a feeling i’m missing something simple… I had previously managed to get multiple apps loaded to iTunes with an older version of Unreal, but can’t remember what version or how. I’ve been using both Mac and PC computers with the same result.

I join Cromo’s question, how to install custom projects separately from each other?
In UE4.5.1 even different games from marketplace override each other, and using that standart “U” icon not custom icons.

Could you post a question to answerhub along with a log of one of the failures from Launch On? My suspicion is the Bundle ID is not getting updated properly as well as the icons and the log might give me some insight as to where that might be failing.

-Pete

btw, I just tested this locally with Tappy Chicken, Memory Game, and Black Jack via Launch (on PC) and they all deployed to the device as separate apps with their own icons. Getting that log would definitely help narrow down what the problem is as it seems like you’ve hit something I haven’t seen yet (and would like to correct :)).

-Pete

Thanx, psauer!
I got answer already via answerhub. I used device unsupported in UE4.5 - ipodtouch4, so… that mess with icons lost meaning now for me. Sory if I confused someone =)

Thanks psauer, sorry for the late reply, been on holiday and put this on the backburner. You were right about the Bundle ID’s but it was just my stupid fault for getting my apple ID’s mixed up when I was launching. I tried with Tappy Chicken, Memory Game and Black Jack and had the same problem so figured I’d missed something.

Just to clarify - to fix it:
I created a new apple ID and Provisioning Profile for each app I wanted to install from the Apple developer website
Downloaded the Provisioning Profiles and put them here C:\Users\USERNAME\AppData\Local\Apple Computer\MobileDevice\Provisioning Profiles
In Unreal - in Project Settings>Platforms>iOS - change the BundleID to be the com.dommainname* or similar ID that comes from the Apple ID
each app needs a unique Bundle ID, ie. a unique Apple ID and provisioning profile

I was just getting lost in the setup for Apple developers, got my head around it now though

Appreciate the help