Download

Apex Destructibles not working, nullptr ApexAsset

Hello eveyone and thanks for reading!

So the past week I have been experiencing a issue where I am trying to make an destructable object through C++ I have got it all working and it works fine in editor. As soon as I export the game (enabling ApexDestructibles) it crashes on setDestructiveMesh with a nullptr to ApexDestructibleAsset.

I have been struggling with this for the last week now and would really apreciate any help or suggestions.
This is in Unreal 4.18 BTW

Theres a few links here to related problems, the first being my own post:
https://answers.unrealengine.com/questions/747922/apex-destruction-nullptr-apex-destructible-asset.html
https://answers.unrealengine.com/questions/721690/apexasset-for-destructiblemesh-not-loading-on-cook.html

This is for a university project and would love to get this sorted.

Thanks in advance!
Joe

Please answer this question. I need an answer to this question as well. Thank you.

I do have the same problem: if I cook with “on the fly” options it works, but the project cannot be deployed. If I cook the package “by the book” all the destructible that worked in the editor don’t work anymore. Sigh… I did a whole game jam assuming it worked an now, at few hours from the deadline, I cannot build a working package … sob :slight_smile: