Download

Apex Cloth Wind Error

Hello,

I hope I’m posting this in the correct place. I’ve been working with the Apex cloth plugin. So far I have got everything set up and working correctly.

However, I have run into a very strange problem I haven’t found anywhere else on the internet. I’ve been searching/troubleshooting for 2-3 hours all over this site, and many others, for an answer (or even a similar issue).
My cloth is not simulating correctly in a specific scene, its hard to explain whats actually happening so here is a link to a gif that highlights the problem. (I would normally try and attach the gif to this thread, but I get a server error everytime I try)

http://i.imgur.com/BFUu3fb.gif

As you can see the larger cloth almost immediately freaks out and start going all over the place. The other smaller cloth simply doesn’t move in the correct way that its supposed to, though it does move in the direction the wind node is pointing.
Its important to note this problem is unique to this scene only. I have tested the exact same assets with an identical wind setup in another scene and the cloth simulates correctly.

Here is a gif showing how this cloth asset is supposed to work:

http://i.imgur.com/gXjvzba.gif

As you can see the cloth is setup correctly. I know that it works, which is why it is so frustrating :mad:. I have also attached a screen grab of the Wind Direction Source settings at the bottom of this post, these settings stayed the same between both scenes, along with the direction of the wind.

Another point worth making is that the scene in which I get this error also has a lot of foliage assets, built using SpeedTree by another artist on my team. I don’t know much about SpeedTree and its wind set up, but could this be causing a clash within this scene? As this issue is specific to this scene and all other scenes I have tested do not have the SpeedTree assets. I have tried detaching all the SpeedTree nodes that create wind in the foliage materials, and that has changed nothing.

Is there anyone who is more knowledgeable about SpeedTree or Apex cloth that could shed some light on this issue? I’m completely stuck and really need to get these assets signed off and implemented.
I’ve tried to supply as much info as I’m allowed, let me know if anyone might need more info.

Thanks.
824baeb264478763e12affa6df2658b4220d0c51.png