Download

Any tips for finding solutions on crashes when upgrading to new engine version?

I have a c++/Blueprints project developed in version 4.10.4 and trying to upgrade to 4.12.5 but of course it crashes when opening the project.

I tried deleting the “Intermediate” and “Save” and “Binaries” folders and then restart the 4.12.5 version, but it still crashes upon loading.

So… I take a look at the log file and crash dump files, etc.

but there’s like 5 crash/log files (WER339A.tmp.WERInternalMetadata.xml, CrashContext.runtime.xml, Report.wer, Dungeon.log, etc.) and not sure which crash log files I should be focusing on.

I looked at them all (opening “UE4Minidump.dmp” shows only garbled characters - I guess I am supposed to open that in a particular program, right?)

but I cannot see exactly where the issue in any of the crash/log files - the errors shown don’t seem really clear on what is causing the issue (or I simply don’t know what they mean)

Below is the log…



Log file open, 07/26/16 09:03:54
LogInit:Display: Running engine for game: Dungeon
LogPlatformFile: Not using cached read wrapper
LogInit:Display: RandInit(-555229620) SRandInit(-555229616).
LogTaskGraph: Started task graph with 4 named threads and 7 total threads with 1 sets of task threads.
LogStats: Stats thread started at 26.052366
LogInit:Warning: Incompatible or missing module: UE4Editor-Dungeon.dll
Running C:/Program Files/Epic Games/4.12/Engine/Binaries/DotNET/UnrealBuildTool.exe Dungeon Development Win64 -project="C:/Users/bfisher777/Documents/Unreal Projects/Dungeon 4.12/Dungeon.uproject" -editorrecompile -progress -noubtmakefiles -NoHotReloadFromIDE  @progress push 5%
Parsing headers for DungeonEditor
  Running UnrealHeaderTool "C:\Users\bfisher777\Documents\Unreal Projects\Dungeon 4.12\Dungeon.uproject" "C:\Users\bfisher777\Documents\Unreal Projects\Dungeon 4.12\Intermediate\Build\Win64\DungeonEditor\Development\DungeonEditor.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed
Reflection code generated for DungeonEditor in 7.8278238 seconds  @progress pop
Performing 9 actions (4 in parallel)
[3/9] Resource ModuleVersionResource.rc.inl
[2/9] Resource PCLaunch.rc
PCH.Dungeon.h.cpp
DungeonBuild.cpp
Dungeon.generated.cpp
Pit.cpp
Wall.cpp
Dungeon.cpp
[9/9] Link UE4Editor-Dungeon.dll
   Creating library C:\Users\bfisher777\Documents\Unreal Projects\Dungeon 4.12\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Dungeon.lib and object C:\Users\bfisher777\Documents\Unreal Projects\Dungeon 4.12\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Dungeon.exp
Total build time: 217.12 seconds
LogInit: Version: 4.12.5-3039270+++UE4+Release-4.12
LogInit: API Version: 2992821
LogInit: Net Version: 3039270
LogDevObjectVersion: Number of dev versions registered: 13
LogDevObjectVersion:   Dev-Blueprints (B0D832E4-1F89-4F0D-ACCF-7EB736FD4AA2): 3
LogDevObjectVersion:   Dev-Build (E1C64328-A22C-4D53-A36C-8E866417BD8C): 0
LogDevObjectVersion:   Dev-Core (375EC13C-06E4-48FB-B500-84F0262A717E): 1
LogDevObjectVersion:   Dev-Editor (E4B068ED-F494-42E9-A231-DA0B2E46BB41): 2
LogDevObjectVersion:   Dev-Framework (CFFC743F-43B0-4480-9391-14DF171D2073): 6
LogDevObjectVersion:   Dev-Mobile (B02B49B5-BB20-44E9-A304-32B752E40360): 0
LogDevObjectVersion:   Dev-Networking (A4E4105C-59A1-49B5-A7C5-40C4547EDFEE): 0
LogDevObjectVersion:   Dev-Online (39C831C9-5AE6-47DC-9A44-9C173E1C8E7C): 0
LogDevObjectVersion:   Dev-Physics (78F01B33-EBEA-4F98-B9B4-84EACCB95AA2): 0
LogDevObjectVersion:   Dev-Platform (6631380F-2D4D-43E0-8009-CF276956A95A): 0
LogDevObjectVersion:   Dev-Rendering (12F88B9F-8875-4AFC-A67C-D90C383ABD29): 2
LogDevObjectVersion:   Dev-Sequencer (7B5AE74C-D270-4C10-A958-57980B212A5A): 0
LogDevObjectVersion:   Dev-VR (D7296918-1DD6-4BDD-9DE2-64A83CC13884): 0
LogInit: Compiled (64-bit): Jul  6 2016 09:09:46
LogInit: Compiled with Visual C++: 19.00.23026.00
LogInit: Build Configuration: Development
LogInit: Branch Name: ++UE4+Release-4.12
LogInit: Command line:  
LogInit: Base directory: C:/Program Files/Epic Games/4.12/Engine/Binaries/Win64/
LogInit: Installed Engine Build: 1
LogInit: Using libcurl 7.41.0
LogInit:  - built for x86_64-pc-win32
LogInit:  - supports SSL with WinSSL
LogInit:  - other features:
LogInit:      CURL_VERSION_SSL
LogInit:      CURL_VERSION_IPV6
LogInit:      CURL_VERSION_ASYNCHDNS
LogInit:      CURL_VERSION_LARGEFILE
LogInit:      CURL_VERSION_IDN
LogInit:  CurlRequestOptions (configurable via config and command line):
LogInit:  - bVerifyPeer = true  - Libcurl will verify peer certificate
LogInit:  - bUseHttpProxy = false  - Libcurl will NOT use HTTP proxy
LogInit:  - bDontReuseConnections = false  - Libcurl will reuse connections
LogInit:  - CertBundlePath = nullptr  - Libcurl will use whatever was configured at build time.
LogOnline:Display: STEAM: Loading Steam SDK 1.32
LogOnline:Warning: STEAM: Steam API disabled!
LogOnline:Display: STEAM: OnlineSubsystemSteam::Shutdown()
LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
LogVoice:Warning: Failed to initialize voice interface
LogInit: Presizing for max 8388607 objects, including 0 objects not considered by GC, pre-allocating 0 bytes for permanent pool.
LogInit: Object subsystem initialized
[2016.07.26-16.07.49:172]  0]LogInit: Selected Device Profile: [Windows]
[2016.07.26-16.07.49:172]  0]LogInit: Applying CVar settings loaded from the selected device profile: [Windows]
[2016.07.26-16.07.49:477]  0]LogInit: Computer: B
[2016.07.26-16.07.49:527]  0]LogInit: User: bfisher777
[2016.07.26-16.07.49:527]  0]LogInit: CPU Page size=65536, Cores=4
[2016.07.26-16.07.49:527]  0]LogInit: High frequency timer resolution =3.507500 MHz
[2016.07.26-16.07.49:824]  0]LogMemory: Memory total: Physical=12.0GB (12GB approx)
[2016.07.26-16.07.49:834]  0]LogMemory: Platform Memory Stats for Windows
[2016.07.26-16.07.49:834]  0]LogMemory: Process Physical Memory: 192.71 MB used, 192.71 MB peak
[2016.07.26-16.07.49:834]  0]LogMemory: Process Virtual Memory: 195.68 MB used, 195.68 MB peak
[2016.07.26-16.07.49:834]  0]LogMemory: Physical Memory: 4450.16 MB used, 12239.20 MB total
[2016.07.26-16.07.49:834]  0]LogMemory: Virtual Memory: 552.70 MB used, 134217728.00 MB total
[2016.07.26-16.07.57:528]  0]LogTextLocalizationManager: No specific translations for ('en-US') exist, so ('en') translations will be used.
[2016.07.26-16.08.04:207]  0]LogD3D11RHI: D3D11 adapters:
[2016.07.26-16.08.04:623]  0]LogD3D11RHI:    0. 'NVIDIA GeForce GT 720' (Feature Level 11_0)
[2016.07.26-16.08.04:623]  0]LogD3D11RHI:       967/0/3072 MB DedicatedVideo/DedicatedSystem/SharedSystem, Outputs:1, VendorId:0x10de
[2016.07.26-16.08.05:006]  0]LogD3D11RHI:    1. 'Microsoft Basic Render Driver' (Feature Level 11_0)
[2016.07.26-16.08.05:006]  0]LogD3D11RHI:       0/0/256 MB DedicatedVideo/DedicatedSystem/SharedSystem, Outputs:0, VendorId:0x1414
[2016.07.26-16.08.05:007]  0]LogD3D11RHI: Chosen D3D11 Adapter: 0
[2016.07.26-16.08.05:078]  0]LogD3D11RHI: Creating new Direct3DDevice
[2016.07.26-16.08.05:078]  0]LogD3D11RHI:     GPU DeviceId: 0x1286 (for the marketing name, search the web for "GPU Device Id")
[2016.07.26-16.08.05:093]  0]LogWindows: EnumDisplayDevices:
[2016.07.26-16.08.05:093]  0]LogWindows:    0. 'NVIDIA GeForce GT 720' (P:1 D:1)
[2016.07.26-16.08.05:093]  0]LogWindows:    1. 'NVIDIA GeForce GT 720' (P:0 D:0)
[2016.07.26-16.08.05:094]  0]LogWindows:    2. 'NVIDIA GeForce GT 720' (P:0 D:0)
[2016.07.26-16.08.05:094]  0]LogWindows: DebugString: FoundDriverCount:3 
[2016.07.26-16.08.05:112]  0]LogD3D11RHI:     Adapter Name: NVIDIA GeForce GT 720
[2016.07.26-16.08.05:114]  0]LogD3D11RHI:   Driver Version: 359.06 (internal:10.18.13.5906, unified:359.06)
[2016.07.26-16.08.05:114]  0]LogD3D11RHI:      Driver Date: 11-24-2015
[2016.07.26-16.08.05:114]  0]LogRHI: Texture pool is 677 MB (70% of 967 MB)
[2016.07.26-16.08.05:159]  0]LogD3D11RHI: Async texture creation enabled
[2016.07.26-16.08.06:178]  0]LogD3D11RHI: GPU Timing Frequency: 1000.000000 (Debug: 2 2)
[2016.07.26-16.08.06:451]  0]LogShaderCompilers: Guid format shader working directory is -25 characters bigger than the processId version (../../../../../../Users/bfisher777/Documents/Unreal Projects/Dungeon 4.12/Intermediate/Shaders/WorkingDirectory/16568/).
[2016.07.26-16.08.06:451]  0]LogShaderCompilers: Cleaned the shader compiler working directory 'C:/Users/BFISHE~1/AppData/Local/Temp/UnrealShaderWorkingDir/26A38D18472F4E45DF4EA9B4ABDB231F/'.
[2016.07.26-16.08.06:451]  0]LogShaderCompilers:Display: Using Local Shader Compiler.
[2016.07.26-16.08.21:391]  0]LogTemp:Display: Loaded TP AllDesktopTargetPlatform
[2016.07.26-16.08.21:408]  0]LogTemp:Display: Loaded TP WindowsClientTargetPlatform
[2016.07.26-16.08.21:443]  0]LogTemp:Display: Loaded TP WindowsNoEditorTargetPlatform
[2016.07.26-16.08.21:461]  0]LogTemp:Display: Loaded TP WindowsServerTargetPlatform
[2016.07.26-16.08.21:476]  0]LogTemp:Display: Loaded TP WindowsTargetPlatform
[2016.07.26-16.08.21:488]  0]LogTemp:Display: Loaded TP AndroidTargetPlatform
[2016.07.26-16.08.21:498]  0]LogTemp:Display: Loaded TP Android_ASTCTargetPlatform
[2016.07.26-16.08.21:507]  0]LogTemp:Display: Loaded TP Android_ATCTargetPlatform
[2016.07.26-16.08.21:538]  0]LogTemp:Display: Loaded TP Android_DXTTargetPlatform
[2016.07.26-16.08.21:561]  0]LogTemp:Display: Loaded TP Android_ETC1TargetPlatform
[2016.07.26-16.08.21:568]  0]LogTemp:Display: Loaded TP Android_ETC2TargetPlatform
[2016.07.26-16.08.21:590]  0]LogTemp:Display: Loaded TP Android_MultiTargetPlatform
[2016.07.26-16.08.21:590]  0]LogTemp:Display: Loaded TP Android_PVRTCTargetPlatform
[2016.07.26-16.08.21:591]  0]LogTemp:Display: Loaded TP HTML5TargetPlatform
[2016.07.26-16.08.21:782]  0]LogTemp:Display: Loaded TP IOSTargetPlatform
[2016.07.26-16.08.21:812]  0]LogTemp:Display: Loaded TP TVOSTargetPlatform
[2016.07.26-16.08.21:826]  0]LogTemp:Display: Loaded TP LinuxNoEditorTargetPlatform
[2016.07.26-16.08.21:839]  0]LogTemp:Display: Loaded TP LinuxServerTargetPlatform
[2016.07.26-16.08.21:949]  0]LogTemp:Display: Loaded TP LinuxTargetPlatform
[2016.07.26-16.08.21:949]  0]LogTargetPlatformManager:Display: Building Assets For Windows
[2016.07.26-16.08.23:948]  0]LogDerivedDataCache:Display: Max Cache Size: 512 MB
[2016.07.26-16.08.27:281]  0]LogDerivedDataCache: Loaded boot cache 3.26s 62MB C:/Users/bfisher777/AppData/Local/UnrealEngine/4.12/DerivedDataCache/Boot.ddc.
[2016.07.26-16.08.27:282]  0]LogDerivedDataCache:Display: Loaded Boot cache: C:/Users/bfisher777/AppData/Local/UnrealEngine/4.12/DerivedDataCache/Boot.ddc
[2016.07.26-16.08.27:282]  0]LogDerivedDataCache: FDerivedDataBackendGraph:  Pak pak cache file ../../../../../../Users/bfisher777/Documents/Unreal Projects/Dungeon 4.12/DerivedDataCache/DDC.ddp not found, will not use a pak cache.
[2016.07.26-16.08.27:282]  0]LogDerivedDataCache: Unable to find inner node Pak for hierarchical cache Hierarchy.
[2016.07.26-16.08.27:282]  0]LogDerivedDataCache: FDerivedDataBackendGraph:  CompressedPak pak cache file ../../../../../../Users/bfisher777/Documents/Unreal Projects/Dungeon 4.12/DerivedDataCache/Compressed.ddp not found, will not use a pak cache.
[2016.07.26-16.08.27:282]  0]LogDerivedDataCache: Unable to find inner node CompressedPak for hierarchical cache Hierarchy.
[2016.07.26-16.08.27:377]  0]LogDerivedDataCache:Display: Pak cache opened for reading ../../../Engine/DerivedDataCache/Compressed.ddp.
[2016.07.26-16.08.27:395]  0]LogDerivedDataCache: Using Local data cache path C:/Users/bfisher777/AppData/Local/UnrealEngine/Common/DerivedDataCache: Writable
[2016.07.26-16.09.01:883]  0]LogInit: Selected Device Profile: [Windows]
[2016.07.26-16.09.02:069]  0]LogContentStreaming: Texture pool size is 0.00 MB
[2016.07.26-16.09.12:896]  0]LogMeshUtilities: No automatic mesh reduction module available
[2016.07.26-16.09.12:896]  0]LogMeshUtilities: No automatic mesh merging module available
[2016.07.26-16.09.12:896]  0]LogMeshUtilities: No distributed automatic mesh merging module available
[2016.07.26-16.09.21:631]  0]LogAssetRegistry: FAssetRegistry took 0.0252 seconds to start up
[2016.07.26-16.09.21:861]  0]LogPackageLocalizationCache: Processed 3 localized package path(s) for 2 prioritized culture(s) in 0.089382 seconds
[2016.07.26-16.09.21:895]  0]LogUObjectArray: 28746 objects as part of root set at end of initial load.
[2016.07.26-16.09.21:895]  0]LogUObjectAllocator: 6069096 out of 0 bytes used by permanent object pool.
[2016.07.26-16.09.21:895]  0]LogUObjectArray: CloseDisregardForGC: 0/0 objects in disregard for GC pool
[2016.07.26-16.10.02:049]  0]LogSlate: SlateFontCache - WITH_FREETYPE: 1, WITH_HARFBUZZ: 1
[2016.07.26-16.10.02:049]  0]LogSlate: SlateFontCache - WITH_FREETYPE: 1, WITH_HARFBUZZ: 1
[2016.07.26-16.11.49:270]  0]LogUdpMessaging: Initializing bridge on interface 0.0.0.0:0 to multicast group 230.0.0.1:6666.
[2016.07.26-16.11.50:704]  0]LogMaterial: Missing cached shader map for material 01_-_Default, compiling. 
[2016.07.26-16.11.54:191]  0]LogMaterial: Missing cached shader map for material rockwalll2048v2_Mat, compiling. 
[2016.07.26-16.11.56:280]  0]LogMaterial: Missing cached shader map for material M_Ground_Moss2, compiling. 
[2016.07.26-16.11.56:597]  0]LogWindows: Windows GetLastError: The operation completed successfully. (0)
[2016.07.26-16.12.25:089]  0]LogWindows:Error: === Critical error: ===
Assertion failed: Object [File:D:\Build\++UE4+Release-4.12+Compile\Sync\Engine\Source\Runtime\Engine\Private\UnrealEngine.cpp] [Line: 7968] 





[2016.07.26-16.12.25:986]  0]LogExit: Executing StaticShutdownAfterError
[2016.07.26-16.12.29:027]  0]LogWindows: FPlatformMisc::RequestExit(1)
[2016.07.26-16.12.29:083]  0]Log file closed, 07/26/16 09:12:29


I thought about starting a new project in 4.12.5 and then somehow “migrating” my old 4.10.4 version files over… but its a big project so there’s many c++ and blueprint files… is that a good solution or is there an easier way?

Any suggestions or tips on how to upgrade a project that won’t open in editor? Thanks.

I was going to mention try deleting your intermediate and saved folders, but looks like you already did that.

Generally speaking I’d try to avoid switching to newer engine versions unless there is something very crucial you need, like a new feature or bug fix.

You could try migrating, but it might turn out messy with the C++ files/project.

Otherwise, it might be good to head on over to the answer hub and post it there. They might have a better idea on what to do with the crash logs.

Have you tried opening it 4.11?

Thanks for replying…

I didn’t really want to upgrade but I think there’s an issue in 4.10.4 that was fixed in later versions regarding rejoining a steam session after leaving - otherwise it kicks you out when you try to rejoin again.

I will post on the answerhub also.

The best way of debugging crashes is to build and run from github source.
The minidump files can be opened from Visual Studio to find where things go wrong, but that, too, needs the source checked out (and the right version of the source to match what you were running!)