AnimGraph - Layered Blend Per Bone not working for me! (VIDEO INCLUDED)

I apologize, I’m a bit cranky in this video. I’m just trying to get it setup so my character doesn’t stop the running animation when moving and swinging. I followed the official tutorial step by step and have a pretty decent grasp on how animation in Unreal Engine works. But for some reason this isn’t working for me. Any help is greatly appreciated!

Humm with out asset in hand.

A blended layer will blend from the parent root through the hierarchy chain so if you set the first chain to the hips or pelvis then then layer could be going in two directions up the torso and down the legs if the both directions is parented.

Instead set the blend to the first spine root and this should force the blend to go up the chain but not back down.

Tried changing the bones with no effect.

Apparently the animation I was playing when he attacks was the regular attack animation, not the montage of it. However, when I created a montage for the attack, he barely starts his swing and then snaps back to idle. So I created a play animation montage for the attack, but then he won’t animate at all!

Which version of the engine?

The tutorial is done using 4.8 and I have a movement controller set up more or less base on the tutorial and works fine in 4.8 but is broken when I run it in 4.9.

If you are doing it in 4.9 then try doing the tutorial in 4.8 and if you migrate it over to 4.9 and does not want to recompile the bp or does not work then something once again got broken.

Okay, I figured it out. Thank you.

Apparently, the montage animation had to be called within the Animation Blueprint graph. I was trying to play it in the character blueprint.