Animation only shows up when root motion is enabled?

So I’ve made my own model, rig, and animation in Blender and imported it into Unreal 5.0. It isn’t a super complicated rig or animation set, just stuff for a prototype. For whatever reason though when I go to view my animations or just have them implemented when playing the game, the model just disappears unless I have Root Motion turned on. This causes problems with some of the stuff I’m trying to implement. The root of my character’s skeleton is at 0,0,0 and does not move at all. Am I missing something I should check box when I export from Blender? Or is this an issue with importing to Unreal? Any help here would be awesome.

Seems scale keyframe is set.

1 Like

Hello IKilledTheBoss, and welcome to the Unreal community.

While using your preferred 3D modeling software, I would check the scale and transform of the mesh whilst performing the animations. I would also check the transform/scale in-engine while the animations are in action.

As noted by MingYueMeow, I would also check the keyframe scaling setting.

Since I am not able to see your import settings, I will provide additional documentation on importing animations to UE5.