Animation not working when enabling Physics


I tried for 2 weeks now to get animation working when enabling physics, but I did not succeed :confused:

As long as physics is disabled, animation just works fine, but as soon as physics gets enabled, everything stops.
Physics Blend Weight is set to 0, tried 1 also, I tried everything :confused:

I know it is hard to figure out what is causing this, but do you have any ideas what maybe could cause this, so I can track down the issue?

It is a vehicle with wheels (not nvidia physx) and the wheels should spin / steer and so on. It is no problem in the code, when I get some random floats in the anim-bp itself, it still doesnt move anything ingame when physics is enabled…

Thanks very much :slight_smile:

Hi ,

Have you tested this against either the regular or advanced vehicle templates in either the Blueprint or C++ templates? If you set your vehicle up differently than these, please send us your file in zip format for further diagnosis. If the file is too large to attach here, you can send it to me via private message on our :

Also, please provide any and all steps to recreate the issue on our end. Providing this information will greatly increase the time it takes to diagnose the issue.



Since we have not heard back from you in a few days, we are closing this post for tracking purposes. If you still need assistance with animating with physics enabled, please respond with the requested information and we will continue to investigate.