Download

Angle based lighting issues

Hi there

I am currently having a bit of a strange issue with lighting. I have created a blueprint with a few static meshes, and a particle system int which emitts light (a basic fire).

The strange thing is that when I look at the fire I get the correct lighting on the walls / floor / ceiling. But when I just nudge the camera slightly to the side, the lighting drops out (its like a switch, not a soft transition). Check out the two screenies:

http://www.team-imx.com/images/UE4/particle_lighting_issue_1.jpg

http://www.team-imx.com/images/UE4/particle_lighting_issue_2.jpg

What could that be? It’s the same in the Editor as well as in game mode.

Cheers,
Michael

Increase the Bounds of your BP if you are using a light source. If it is particles with a light module then increase the Bounds of your particle system.

Solved! Thanks, Jacky. I used a light module by the way.

The bounds are a very annoying optimization method especially for particles that travel long distance from the center. I would ask Epic for an integrated null value that means infinite like 0 or -1.

If that is a feature already included i would like to know.

It’s definitely something you have to know. I wouldn’t have attributed my issue to the particle system bounds value to be honest…

Yes and I don’t really remember seeing these extra setting that the right click details has from inside cascade. I had to look at the content browser and open details to get some of them. Just like the fixed bounds located at top, Think we should have in the same dropdown the values tab for the bounds too.

Yep, room for improvement, I would say :wink: