Android project freezes on quit when running on Vulkan


I have a recurring problem with my Android projects, when running on Vulkan only.
The game runs really well on Vulkan, @60fps in HDR Mobile on my Galaxy Note 8 and I get impressive results…
But when I quit the app, via the “quit” command in console mode or in the menu I implemented in my game, the game seems to quit, but “freezes” on the last image and doesn’t go back to the Android OS Home page, it remains on the last image of the game. When I run the game in OpenGL ES it doesn’t have this problem, it quits normally and releases the resources, getting back to the home menu of Android. Android remains responsive and by activating the menu button on the smartphone, it’s getting back to the home menu of Android, and you can close the app from the multitask menu (it seems to be already exited). Could it be just a “video memory last frame freeze” or something like that ?
I don’t know how to solve this problem, and though it is not a deal breaker, since Vulkan runs really well and you just have to push the home button of your device it is no big deal, but still, it’s really annoying and looks like a crash to users, so I can’t sell the game like that.
Any idea of what could cause this problem ?
I tried on UE4 4.18 and 4.19, on Samsung Galaxy S7 Edge and Galaxy Note 8, on 3 different projects and with exactly the same results.