Android launch crash when set NDK to android-19

My phone is Zenfone 2 (ZE551ML), UE4 is Github 4.10.4 source-build.

I have NVPACK 1R3 installed with API 19 and 21.

I tried TappyChicken project and launch successfully when:
Support armv7 [aka armeabi-v7a] unchecked
Supprt x86 checked
Support OpenGL ES2 checked
Support OpenGL ES41 + AEP unchecked
NDK API Level set to android-21

But cannot launch if I changed:
NDK API Level android-19. The game crash after the splash screen prompt. No error in output window.

Any idea?

Flim,

In order to better assist you, I will need to see your output error logs from the editor as well as the logcat files from your device. Please upload them as a .txt file separately so they’re not mixed up.

If you’re not sure how to get logs from the engine, please do the following: Window > Developer Tools > Output Log

If you’re not sure how to get the logs off of your phone, please follow this information: C:\NVPACK\android-sdk-windows\tools and open up Monitor.bat.

Please do not forget that you have to highlight and select all of the logs in order to get them to save when using Monitor.bat.

Thanks!

Hi Samatha,

Enclosed are the log.txt from Android and Output_log.txt from UE4. I use TappyChick project to test. It runs fine if the SDK is android-21, but failed with android-19.

Thank you!

Frederick

link text

Could I have the logs from Android-19 that’s causing all of the errors for comparison?

Thanks!

Hey Flim,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!