Download

Android App giving XAPK File Validation Error no matter what I Try :(

Help! I’m really stuck on this and have not found a solution yet. I’m literally losing my mind over trying to figure this problem out. I’m not even sure why this is a problem because the test build installed via debugging works fine now but why is it all of a sudden an issue after publishing a Google Play Early Access Beta. I’m tempted to pull it but it’s motivating me more to fix it (luckily I don’t have very many users yet which is likely due to the issue). I’ve kept it small intentionally for the moment until hopefully I can learn from any mistakes to fix it.

So far I’ve tried -

  1. Unticking/Reticking Pak
  2. Tried Tweaking a few other settings per https://docs.unrealengine.com/en-US/…ize/index.html (haven’t tried the plugins option yet though, I left that at the default for now so maybe that is related?)
  3. Enabling ExternalStorageDir (not so sure this is a good idea because I’ve noticed that doing this turns the storage switch off in the game by default after install?)
  4. I heard theres a way to check if the obb is in there but not sure how to check that? I am thinking maybe mine is too big or something? I noticed when I cook it generates an obb file and an apk file in the folder after packaging. Mine is kinda large, not really sure how to shrink that down more and its a low poly game so i have no idea why it’s that big, could that be causing the issue? I’m very new to making android games. If I pack the obb file into the apk then its way too big, not sure how to work around that problem.
  5. Only other thing I can think of is a full rebuild by migrating to a new project and trying to reduce it more, not sure how far I can go on that further to clean it up more.

Any other ideas or advice here?

Anyone know if there a way I can somehow debug the issue from the downloaded app?

Not sure at this point other than to scrap the game project since I am striking. Also, I’m a visual learner.